PDA

Visualizza la versione completa : Xorg aggiornato


RokStar
01-09-2011, 15:27
Ieri sera ho dato un apt-get dist-upgrade e tra le altre cose si č aggiornato anche Xorg.
Oggi accendo il pc e il server X non parte. Ok, scarico gli ultimi driver NVidia, li installo, poi controllo il var/log/Xorg.0.log | grep EE e vedo che dice di usare l'opzione -IgnoreABI per usare i driver NVidia, quindi vim /etc/X11/xorg.conf modifica del file inserendo Option "IgnoreABI" "1".
Il server X a questo punto parte, ma sembra che ci sia un po' di "spazzatura" sullo schermo, vale a dire scritte che rimangono e che non vanno via quando dovrebbero, pulsanti un po' strani e via di seguito. L'ambiente desktop č XFCE, ma non credo dipenda da lui. Devo usare i driver nvidia di Xorg e non quelli della nvidia? :nonlodire

paolino_delta_t
01-09-2011, 18:25
Hai verificato che stia usando il driver nvidia e non nouveau?

E il file di configurazione di X? Le nuove versioni non usano pių xorg.conf ma vogliono un'entry nella directory xorg.conf.d

In genere si chiama 20-nvidia.conf il file e contiene questo

Section "Device"
Identifier "Default nvidia Device"
Driver "nvidia"
Option "NoLogo" "True"
EndSection

lion1810
02-09-2011, 13:30
Le nuove versioni non usano pių xorg.conf ma vogliono un'entry nella directory xorg.conf.d

si cambia ancora????
Sono rimasto indietro..
da che versione?

paolino_delta_t
02-09-2011, 19:19
Originariamente inviato da lion1810

Le nuove versioni non usano pių xorg.conf ma vogliono un'entry nella directory xorg.conf.d

si cambia ancora????
Sono rimasto indietro..
da che versione?

non ricordo quale versione ma č da almeno 6-7 mesi che sulla mia arch ho notato il cambiamento

Loading