PDA

Visualizza la versione completa : Problema pid utente samba


8bitmagictime
05-09-2011, 09:15
Ho un problema con un file server virtualizzato samba, su Scientific Linux 5.2. Succede che durante operazione di apertura o di copia di cartelle o file, l'operazione si blocchi. Accedendo tramite ssh al server virtuale e lanciando il comando smbstatus, quando ci sono queste anomalie, l'utente al quale capita l'errore ha un pid duplicato. Sembra quasi che durante l'operazione la connessione venga abbattuta e ne venga creata un'altra che però si trova con file bloccati dalla precedente. Quale può essere il problema?

superbubba
06-09-2011, 14:41
Che versione di Samba stai usando? Anch'io in passato ho avuto un problema simile che si è banalmente risolto aggiornando Samba.

8bitmagictime
07-09-2011, 08:19
La versione, da quanto riportato da smbstatus è questa: Samba version 3.0.33-3.29.el5_5.1

superbubba
08-09-2011, 18:20
Tieni conto che per SL 5 esiste ora la versione 3.0.33-3.29.el5_6.2 che puoi ottenere semplicemente con uno:

yum update samba*

Magari prima di procedere fatti una copia di backup dell'intera cartella /etc/samba. E' un minor update e tutto dovrebbe filare liscio senza intoppi.

Se la situazione non dovesse migliorare allora ti consiglio di passare ai pacchetti samba3x (ad oggi contengono Samba 3.5.4), sempre forniti dai repository ufficiali SL 5. La migrazione è un po' più delicata ma ti assicuro che si tratta di un'ottima release che uso correntemente su diversi server di produzione. Ormai ho abbandonato il ramo 3.0 da tempo, era diventato impossibile lavorare soprattutto con Windows Vista e Seven in circolazione.

8bitmagictime
08-09-2011, 22:19
Grazie per il consiglio, proverò l'upgrade. Il computer che mi dava problemi ha XP mentre non ho problemi ne con altri XP ne con computer dotati di Ubuntu o di Mac OS X Snow Leopard.

Loading