PDA

Visualizza la versione completa : problemi con grub


gabrriy87
05-10-2011, 15:21
salve ragazzi......ieri mentre usavo felicemente il mio portatile all'improvviso si è spento e non è piu partito... dopo vari tentativi ho scoperto che l'hard disk è "morto" non da piu segni di vita... poco male mi sono detto... prendo un hard disk lo formatto con un altro computer e lo inserisco nel portatile ma quando lo accendo mi dice "error:no such partition", grub rescue> . Bene mi mobilito per trovare soluzioni su internet ma con il mio vecchio computer non posso seguire le normali procedure perchè non ho il lettore cd e non posso far avviare niente da usb perchè ilBIOS non lo supporta..... avete qualche soluzione a riguardo??????

psykopear
05-10-2011, 17:47
Originariamente inviato da gabrriy87
salve ragazzi......ieri mentre usavo felicemente il mio portatile all'improvviso si è spento e non è piu partito... dopo vari tentativi ho scoperto che l'hard disk è "morto" non da piu segni di vita... poco male mi sono detto... prendo un hard disk lo formatto con un altro computer e lo inserisco nel portatile ma quando lo accendo mi dice "error:no such partition", grub rescue> . Bene mi mobilito per trovare soluzioni su internet ma con il mio vecchio computer non posso seguire le normali procedure perchè non ho il lettore cd e non posso far avviare niente da usb perchè ilBIOS non lo supporta..... avete qualche soluzione a riguardo??????

se l'hai formattato probabilmente è rimasto un grub da una precedente installazione linux su mbr, ma non essendoci nient'altro nell'hd non trova le partizioni e non parte. Indi per cui, installaci sopra almeno un sistema operativo, non può partire nulla da hard disk se dentro non c'è niente

gabrriy87
07-10-2011, 15:05
ok ma per installare un sistema operativo sull'hard disk devo farlo da un altro computer e quando poi lo reinserisco nel portatile nn parte lo stesso..
nn c'è un modo per non far partire grub?

psykopear
07-10-2011, 15:56
Originariamente inviato da gabrriy87
ok ma per installare un sistema operativo sull'hard disk devo farlo da un altro computer e quando poi lo reinserisco nel portatile nn parte lo stesso..
nn c'è un modo per non far partire grub?

No solitamente per installare un os è consigliabile farlo dal pc stesso in cui questo dovrà funzionare, almeno in fase di installazione si configurerà per l'hardware giusto. Un boot loader ci deve essere in ogni caso, che sia quello di windows, o un grub, in ogni caso è necessari oche ci sia un sistema operativo funzionante sull'hard disk, e solitamente mentre lo installi ci pensa lui a mettere il proprio bootloader nell'mbr, quindi la soluzione rimane sempre quella, metti l'hd nel portatile, parti con un cd (o penna usb o quello che vuoi) di installazione di un qualunque sistema operativo (metti prima windows se vuoi fare un dual boot), e procedi con l'installazione che sistemerà da sè il bootloader

gabrriy87
07-10-2011, 20:50
se avessi avuto la possibilità di installare dal mio portatile la soluzione l'avrei gia trovata....
mi sono rivolto al forum perchè come ho scritto nel primo post non ho il lettore cd e non posso far avviare niente da usb perchè il portatile no lo supporta...
non ci sono altri modi per far ripristinare il bootloader? e se provo ad installare linux tramite netbootin dite che riesco o mi avvia subito "grub"?
pero dopo non posso piu installare windows!?!!??!?

gabrriy87
08-10-2011, 11:45
non so se sto facendo qualche passo avanti o mi sto arenando ancora....
ho riesumato un mio vecchio portatile che aveva installato windows ME ho tolto l'hard disk e l'ho messo nel mio portatile che non parte piu e magicamente il comp si è acceso ma funziona solo in modalità provvisoria.....
ora per cancellare GRUB dovrei digitare da DOS FDISK/MBR giusto?
quando digito il comando però il terminale in dos non mi da segni di vita e mi riporta in c:WIndows.... sbaglio qlcs? qst operaziono riesco a farle solo con l'hard disk del vecchio computer..... e se riesco a reinstallare ME sul nuovo hard disk?!?!?!?
aiutatemi per favore :messner:

francofait
08-10-2011, 12:11
Se non resituisce alcun avviso il comando è stato eseguito correttamente:

fdisk /mbr

non fdisk/mbr # in questo modo viene assunto come un unica stringa di testo , il comando di conseguenza risulta inesistente.

gabrriy87
08-10-2011, 17:27
ok se è andato tutto ok perchè quando inserisco l'hard disk formattato mi parte ancora grub e mi da errore??
io penso che dovrebbe solo dirmi che nell'HD nn c'è niente o un errore del genere...

Loading