PDA

Visualizza la versione completa : Ubunto 10.10 dopo upgrade non si avvia


centro
17-10-2011, 09:44
Ciao a tutti,
Allora l'altro giorno ho lanciato l'aggiornamento da 11.04 a 11.10.. così quindi hop lanciato ed ho abbandonato il pc.
Stamattina mia moglie mi ha detto che il pc sembrava bloccato elo ha riavviato.

Fatto sta che ora non si riesce più ad avviare.. l'avvio si ferma sulla scritta ubuntu per qualche minuto e poi si riavvia..

non so cosa fare... daltronde oltre la problema... qui rischio il matrimonio :)
mia moglie aveva un documento che gli serviva stamattina.

Me lo sono portato a lavoro... ora il pc ma ancora non vedo luce....
mi date qualche consiglio sul da farsi...
qualsiasi suggerimento è ben accetto :)

giuseppe

furly
17-10-2011, 10:01
Per recuperare il documento, utilizza una qualsiasi distro live (anche Ubuntu stessa), accedi alla partizione contenente il doc e salvalo su chiavetta usb.

Per Ubuntu il mio consiglio personale è quello di non eseguire l'avanzamento di versione.
Dico questo perchè con l'upgrade ho sempre avuto più problemi di quelli che ho avuto installando da zero.

bereshit
17-10-2011, 12:05
usa una live epr recuperare i tutti i dati ,

poi formatta

per l'avanzamento di versione, personalmente avanzo da anni è non ho mai avuto problemi

ma a volte pare che capitino quindi un bel backup è sempre d'obbligo (andrebbe fatto cmq a prescindere)

centro
17-10-2011, 15:10
allora per recuperare i dati.. entrando in modalità ripristino da shell ho copiato tutto su una chiavetta..

quaindi almeno il matrimonio è salvo :)

possibile ora che per avviare il pc mi tocca piallarlo... dai... non ci credo.. o meglio non ci voglio credere :)

furly
17-10-2011, 16:11
Boh...
Prova ad avviarlo in modalità ripristino e poi aggionare.
Magari succede qualcosa...

centro
17-10-2011, 17:14
ma nemmeno in modalità di ripristino mi si avvia.
se da shel faccio startx sembra che si sta avviando e poi da un

FATAL: module nvidia_current not found
ed una serie di righe riguardati nvidia .. crdo non trovi più i driver.

Ma non posso rimettere in qualche modo la versione che avevo la 11.04 o devo per forza formattare :)

MItaly
17-10-2011, 17:41
In modalità single user riesci ad ottenere una shell? Da lì prova un apt-get update e un apt-get dist-upgrade in modo da completare l'aggiornamento. Se apt è rimasto incasinato potrebbe essere necessario un dpkg-reconfigure -a.

bereshit
17-10-2011, 17:48
la 11.04 no

perchè quantomeno si sarà emzzo aggiornata

è un dowgrade è sconsigliabile

puoi provare a modificare xorg da live e dirgli di usare i driver vesa

poi avviare da modalità ripristino

e completare l'upgrade come ti è stato detto

cmq secondo me la cosa più veloce è piallare

francofait
17-10-2011, 19:00
il downgrade non è sconsigliabile è semplicemente impraticabile , inoltre non ne vedo motivo .
Procedere da console avviando in modalità ripristino , a suon di :

sudo dpkg --force-all --configure -a
sudo apt-get -f install
sudo apt-get update
sudo apt-get -f dist-upgrade


Comunque la miglior soluzione a quel punto rimane una sana e pulita reinstallazione exnovo , oltretutto è anche sempre sia più rapida che più sicura di qualunque avanzamento versione.

centro
18-10-2011, 09:21
HO RISOLTO e posto la soluzione per qualche anima pia come me :)

girovagando su internet
grazie a questi comandi speciali.. :) sono riuscito ad avviare 11.10

una volta che ti sei loggato vai con
Codice:

dpkg --list |grep nvidia

nell'elenco dei pacchetti ci deve essere nvidia-current se no nc'è installalo.(io c'è l'avevo ma l'ho reinstallato lo stesso)


sudo apt-get install nvidia-current

lanciando la prima volta apt-get install mi ha mi ha detto che bisognava prima configurare dpkg, e mi ha suggerito il comando.
Questa cosetta è durata un bel pò poi ho installa nvidia-current ed ecco fatto.
ciao e grazie

E mi sono evitato di reinstallare il tutto!
buona giornata
Giuseppe

Loading