PDA

Visualizza la versione completa : yum error


snomato
21-10-2011, 17:06
ciao,
sto cercando di far accedere da una macchina al repository di un'altra collegate (naturalmente) in rete. sistema operativo red hat enterprise 6

ho startato il servizio httpd
ho linkato il file dove sono presenti i repo
.....

[My_Repository]
name=My_Repository2
baseurl=http://mik73.redhatdesktop2/repo
enabled=1
gpgcheck=0

ho disattivato anche SELINUX

sapete da cosa dipende questo errore?
http://mik.redhatdesktop2/repo/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - "couldn't connect to host"
le macchine si pingano correttamente, l'iptables disabilitato...
grazie

charlieroot
21-10-2011, 18:40
Domanda stupida, ma sei sicuro che http://mik73.redhatdesktop2/repo sia giusto? Perch cos ad occhio quando yum va a scaricarsi l'xml coi metadati del repository d un'errore di connessione.

Nel caso sia giusto ( magari a fare un wget da locale per verificarlo ) controlla che quando dai



createrepo /example/example_repo/


poi effettivamente sia la directory nella root di apache, che nel tuo caso dovrebbe essere cos ad occhio /var/www/html/repo/

snomato
22-10-2011, 12:34
il path l'ho scritto in entrambi i modi (baseurl=http://mik73.redhatdesktop2/repo e baseurl=http://mik73.redhatdesktop2/repo/) ma non funziona in entrambi i modi.


il comando createrepo l'avevo gi eseguito sullo stesso repo locale che funziona. devo lanciarlo una seconda volta?

httpd.conf

ServerAdmin root@localhost
DocumentRoot /var/www/html
ServerName 192.168.56.101

charlieroot
22-10-2011, 16:01
Dunque, devi chiamare createrepo ogni volta che aggiorni i l repository togliendo / aggiungendo pacchetti.

Quello che mi sembra che la configurazione di yum punti ad una directory non raggiungibile.

Nel pc server, la directory del repository /var/www/html/repo?

Avete una proxy?

Hai provato ad usare l'ip invece del dns?

es. baseurl=http://192.168.1.X/repo

snomato
24-10-2011, 16:06
non ho aggiunto o modificato nessun pacchetto e il repodata mi risulta funzionante per le installazioni in locale.

[root@mik73 2]# ll /var/www/html/repo
lrwxrwxrwx. 1 root root 16 Oct 21 01:39 /var/www/html/repo -> /root/filecdrom/

nessun proxy

ho provato ad inserire anche l'ip

[My_Repository]
name=My_Repository2
baseurl=http://192.168.56.101/repo/
enabled=1
gpgcheck=0

error log di apache:
[Fri Oct 21 01:39:16 2011] [error] [client 192.168.56.3] Symbolic link not allow
ed or link target not accessible: /var/www/html/repo
[Fri Oct 21 01:58:02 2011] [error] [client 192.168.56.3] Symbolic link not allow

come postato sopra i permessi chmod sono 777

charlieroot
24-10-2011, 18:14
Penso che il problema possa essere il link simbolico, se non indispensabile dovresti provare a copiare il repository su quella cartella.

Altrimenti invece di usare il link simbolico dovresti provare a creare un'alias di apache.

snomato
04-11-2011, 14:37
grazie charlie ho risolto...
era errato il link come dicevi tu :dh:

charlieroot
04-11-2011, 15:44
Figurati, se non ci si aiuta tra linuxisti... non si linuxisti... :)

Loading