PDA

Visualizza la versione completa : [ruby] problema con mysql


TommyR22
30-10-2011, 20:39
ciao a tutti!
ho dei problemi nell'installare la gemma mysql2.
in pratica ho installato ruby 1.8.7,rails 3.0 e mysql 5.1.
Adesso devo creare un sito con mysql e quando vado a fare il comando : rails new provasito -d mysql
mi da questo errore! :dh:

ERROR installing mysql2:failed to build gem native extension


ho provato a fare qualsiasi cosa anche a disistallare tutto e installare tutto pian piano..ho seguito anche certe guide ma niente..non riesco a risolvere il rpoblema.Con sqlite3 il tutto funziona..con mysql no :nonlodire

grazie :)

weppos
23-11-2011, 14:04
Manca il messaggio d'errore completo.


ERROR installing mysql2:failed to build gem native extension

significa che Ruby non riuscito a compilare la libreria C contenuta nella Gem.
Assicurati che tu abbia un compilatore C installato sulla macchina.

Se sei su Linux o Mac abbastanza semplice (gcc o xcode), su Windows un incubo.

Loading