PDA

Visualizza la versione completa : Eeepc ubuntu non parte più


mykol
01-12-2011, 19:46
Ciao,
stamattina ho usato il mio EeePC con ubuntu appena acquistato e sembrava tutto OK. L'ho spento regolarmente, ora ho cercato di avviarlo ma non parte l'interfaccia grafica (non arriva nemmeno al login), si ferma con, tra le altre, questa scritta (non riesco a postare l'immagine, il file è più grande di quanto il forum lo accetti ..)......

Alert! /dev/disk/by-uuid/e qui l'uuid ... does not exist ! Dropping to a shell !

e si ferma con la scritta

(initramfs) ed il cursore lampeggiante ...

Ovviamente il disco esiste, perchè se lo carica fin li !???

Cosa devo fare ? Suggerimenti ?

Grazie

sacarde
01-12-2011, 20:09
all'avvio di GRUB

premendo shift entri nel menu

premendo "e" editi le voci del menu

la voce del kernel, togli il riferimento root=UUID alla partizione
e la sostituisci con la partizione /dev/sd... (esempio /dev/sda1)

mykol
01-12-2011, 21:11
In grub c'è questo ...

recordfail
insmod part_msdos
insmod ext2
set root='(hd0,msdos3)'
search --no-floppy ecc... ecc...
linux /boot/vmlinuz-2.6.35-28-generic root=UUID=f87........... ro quiet splash
initrd /boot/initrd.img-.....................

in base a quanto sopra come potrebbe chiamarsi la partizione, hd0 ?

Domanda assai banale, ma come si salvano le modifiche e si esce ?
L'aiuto in linea dice "Ctrl-x to boot" ma in questo modo riavvia il pc senza salvare le modifiche. Che combinazione di tasti bisogna usare ?

Grazie.

sacarde
02-12-2011, 09:05
una volta avviato controlla:


(i nomi delle partizioni): sudo fdisk -l

(i nomi uuid): sudo blkid


correggi il riferimento oppure metti la denominazione /dev/sd.....

sia in grub che in: /etc/fstab


per reinstallare grub2:


grub-install /dev/sda
update-grub2



p.s.
http://wiki.ubuntu-it.org/AmministrazioneSistema/Grub/Ripristino

mykol
02-12-2011, 10:39
l primo problema è che non ho il cd (né la chiavetta) live

Il secondo è che dopo aver avviato dal menù di avvio testuale che appare si ferma come ho indicato sopra

Il terzo è che quando modifico il menù di avvio (sostisuendo l'UUID con /dev/sd...) non riesco a salvarlo (Ctrl+x esce senza salvare ...) cosicché mi ritrovo sempre daccapo ...

PS. Se questo doveva essere un sistema facile, inizio a capire perché quasi tutti quelli che l'hanno comprato se lo sono fatti cambiare con uno win !

Grazie della pazienza ovviamente !

sacarde
02-12-2011, 13:34
ma almeno dovrebbe salvarlo per la sessione attuale

a me una volta modificato, con "ctrl-x" si avvia modificato



p.s.
se il problema fosse nella denominazione in fstab, occorre una chiavetta-live per
montare il filesystem e modificare /etc/fstab mettendo anche li /dev/sd....

mykol
02-12-2011, 14:08
la soluzione radicale sarebbe reinstallare il sistema. Avviando dopo aver premuto F9 inizia la procedura di reinstallazione dall'immagine presente in una partizione di recupero. Ma è proprio l'ultima spiaggia, mi dispiace perdere le personalizzazioni fatte.

francofait
02-12-2011, 14:24
le personalizzazioni sono configurazione utente . Prima di fare il ripristino alle condizioni iniziali con una qualunque live su pennina ti vai ha salvare l' intera configurazione utente in modo da pterla poi ripristinare.

mykol
03-12-2011, 14:11
ho reinstallato, certo che non mi era mai successo che un SO mi durasse meno di due giorni, nemmeno ai tempi gloriosi di Window Me.

Beh, quanto prima mi metter; alla ricerca di una distrbuzione seria e funzionante per il piccolino ...

Come vedete neppure la tastiera [ giusta *la prima cosa che scrivo( nonostante durante l-installazione abbia selezionato quella italiana, appena riavviato mi trovo quella USA. Una vera meraviglia !

psykopear
03-12-2011, 19:42
Originariamente inviato da mykol
ho reinstallato, certo che non mi era mai successo che un SO mi durasse meno di due giorni, nemmeno ai tempi gloriosi di Window Me.

Beh, quanto prima mi metter; alla ricerca di una distrbuzione seria e funzionante per il piccolino ...

Come vedete neppure la tastiera [ giusta *la prima cosa che scrivo( nonostante durante l-installazione abbia selezionato quella italiana, appena riavviato mi trovo quella USA. Una vera meraviglia !

metti arch :D

Loading