PDA

Visualizza la versione completa : [vim] sintassi e colori


james
06-12-2011, 11:29
Quando uso Vim mi accade una cosa che non mi so spiegare.
Se edito un file, ad esempio di configurazione di Apache (quelli dei VirtualHost per intenderci), su alcuni ho una colorazione per evidenziare la sintassi corretta, su altri file invece, la colorazione è assente, o addirittura diversa. Premetto che Apache accetta tutti i files senza generare nessun warning, mi chiedo allora, perché vim a volte applica la colorazione corretta ed altre volte no. Uso ubuntu server, l'ultima rilasciata...

untamed
06-12-2011, 21:15
ma con lo stesso utente o con utenti diversi? perchè solitamente le impostazioni di quel tipo si trovano nel file .vimrc nella home dell'utente. altrimenti ci potrebbe anche essere un file /etc/vimrc, le impostazioni che vai a scrivere lì valgono per tutti gli utenti.

james
06-12-2011, 21:26
Originariamente inviato da untamed
ma con lo stesso utente o con utenti diversi? perchè solitamente le impostazioni di quel tipo si trovano nel file .vimrc nella home dell'utente. altrimenti ci potrebbe anche essere un file /etc/vimrc, le impostazioni che vai a scrivere lì valgono per tutti gli utenti.

me lo fa con lo stesso utente, come se rilevasse qualche errore di sintassi o caratteri che mandano in palla vim , tipo caratteri di accapo fatti con piattaforme diverse...boh...

sacarde
06-12-2011, 21:48
quali sono questi file?

james
06-12-2011, 22:55
Originariamente inviato da sacarde
quali sono questi file?
sono classici file di apache dei virtual host , la sintassi è corretta in ogni caso perché apache non mi da nessun warning

sacarde
07-12-2011, 09:02
io su arch vedo tutte le configurazioni colorate


potresti postare la configurazione che non te la colora

james
07-12-2011, 09:23
Originariamente inviato da sacarde
io su arch vedo tutte le configurazioni colorate


potresti postare la configurazione che non te la colora

ho scoperto il problema. Vim mi legge l'estensione del file. Essendo file di Apache VirtualHost, il nome del file coincide con il dominio relativo, ed il suffisso del nome del file è ad esempio .com, in questo caso tutta la colorazione è sballata, se lo rinomino in _com anziché .com la colorazione è corretta...un altro po' e uscivo matto!

Loading