PDA

Visualizza la versione completa : Rete debian


starcraftworld
25-12-2011, 13:20
Il mio debian, che fino a qualche giorno fa andava in internet regolarmente connesso al router via ethernet, ora non mi trova pił nessuna rete. Eppure la rete funziona perchč dallo stesso pc riesco a connettermi a internet tramite sistemi operativi diversi. Cosa posso fare?

sacarde
25-12-2011, 13:47
il device eth0 lo crea?
lo vedi da: ifconfig


poi se sul router hai il dhcp prova a chiedere l'IP a mano:
dhclient eth0


p.s.
potrebbe essere un priblema di dns
prova se risponde: ping 173.194.69.104

p.s.
hai aggiornato qalcosa?

starcraftworld
26-12-2011, 15:56
Si, eth0 lo crea.


debian:/home/utente# dhclient eth0
Internet Systems Consortium DHCP Client V3.1.1
Copyright 2004-2008 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth0/00:17:31:d9:24:7c
Sending on LPF/eth0/00:17:31:d9:24:7c
Sending on Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 17
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 20
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 16
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

sacarde
26-12-2011, 16:58
vedi errori?

dmesg | grep eth0

o in /var/log/messages riguardo eth0 ?



p.s.
hai fatto qualche aggiornamento?

hai il dhcp sul router vero?

starcraftworld
03-01-2012, 23:57
debian:/home/utente# dmesg | grep eth0
[ 5.372593] eth0: VIA Rhine II at 0x19400, 00:17:31:d9:24:7c, IRQ 23.
[ 5.373309] eth0: MII PHY found at address 1, status 0x786d advertising 01e1 Link 41e1.
[ 15.340123] eth0: link up, 100Mbps, full-duplex, lpa 0x41E1
[ 27.572015] eth0: no IPv6 routers present

sacarde
04-01-2012, 08:47
provato?


Originariamente inviato da sacarde
...

- poi se sul router hai il dhcp prova a chiedere l'IP a mano:
dhclient eth0


- potrebbe essere un priblema di dns
prova se risponde: ping 173.194.69.104

...

starcraftworld
05-01-2012, 15:17
debian:/home/marco# dhclient eth0
Internet Systems Consortium DHCP Client V3.1.1
Copyright 2004-2008 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth0/00:17:31:d9:24:7c
Sending on LPF/eth0/00:17:31:d9:24:7c
Sending on Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 12
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

debian:/home/marco# ping 173.194.69.104
connect: Network is unreachable

sacarde
05-01-2012, 17:02
mah !
non capisco, eth0 lo crea ma non trova il server dhcp (hai fatto aggiornamenti?)

usi un network-mamager ? o wicd ?

potresti provare se con un'interfaccia grafica cela fa



http://www.debian.org/doc/manuals/debian-reference/ch05.it.html#_the_modern_network_configuration_for _desktop

starcraftworld
05-01-2012, 19:24
Non ho fatto aggiornamenti.
Non uso nessun network manager (credo) e wicd non so nemmeno cosa sia :)
Come faccio a provare se con l'interfaccia grafica ce la fa?

sacarde
05-01-2012, 21:01
per riavviare network-manager

Riavviare NM con il comando seguente.

sudo /etc/init.d/network-manager restart


altrimenti :

sudo /etc/init.d/network restart

Loading