PDA

Visualizza la versione completa : Problema aggiornamento Centos


Eric Mix
05-05-2012, 22:55
Salve,

Dopo aver aggiornato centos da 5.5 a 5.8 mi ritrovo con questi kernel
2.6.18-194.3.1.el5xen
2.6.18-308.4.1.el5xen

Il file grub.conf è il seguente

default=1
timeout=10
title CentOS (2.6.18-308.4.1.el5xen)
root (hd0,0)
kernel /boot/vmlinuz-2.6.18-308.4.1.el5xen console=xvc0 root=/dev/sda1 ro /dev/sda2
initrd /boot/initrd-2.6.18-308.4.1.el5xen.img
title vmlinuz-2.6.18-194.3.1.el5xen
root (hd0,0)
kernel /boot/vmlinuz-2.6.18-194.3.1.el5xen console=xvc0 root=/dev/sda1 ro
initrd /boot/initrd-2.6.18-194.3.1.el5xen.img

Se imposto default=0 non si avvia :confused:

sacarde
06-05-2012, 10:45
che errore da?


che ci fa il parametro: "/dev/sda2" ?

Eric Mix
06-05-2012, 15:06
Originariamente inviato da sacarde
che errore da?Non lo so perchè non si avvia e sono su una macchina virtuale xen, stavo facendo una prova.


che ci fa il parametro: "/dev/sda2" ? lo mette lui in automatico dopo aggiornamento da 5.5 a 5.8

sacarde
06-05-2012, 17:57
Originariamente inviato da Eric Mix
Non lo so perchè non si avvia e sono su una macchina virtuale xen, stavo facendo una prova.


ma grub parte?






lo mette lui in automatico dopo aggiornamento da 5.5 a 5.8


che c'e' in sda2 ?

Eric Mix
06-05-2012, 21:58
Originariamente inviato da sacarde
che c'e' in sda2 ? C'è la partizione swap :confused:

sacarde
06-05-2012, 22:03
quando parte grub, puoi editare la riga del kernel e... io... proverei a togliere /dev/sda2

Eric Mix
06-05-2012, 23:22
Per adesso rinuncio a sta cavolo di macchina virtuale visto che non ne vengo a capo.

Grazie di tutto ;)

Eric Mix
19-05-2012, 22:11
Oggi ho riacceso la macchina virtuale.. problema trovato era nell'errata configurazione della swap in fstab

Loading