PDA

Visualizza la versione completa : Problema Terminale


dav78
02-06-2012, 01:36
Ciao a tutti! Ogni volta che digito da terminale: " sudo apt-get install build-essential" mi esce il seguente messaggio :


Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
build-essential è già alla versione più recente.
0 aggiornati, 0 installati, 0 da rimuovere e 19 non aggiornati.

mentre quando digito da terrninale: " sudo apt-get install checkinstall " mi esce la seguente dicitura:


Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
checkinstall è già alla versione più recente.
0 aggiornati, 0 installati, 0 da rimuovere e 19 non aggiornati.


Vorrei sapere gentilmente come risolvere questo problema.

MItaly
02-06-2012, 01:44
Non c'è nessun problema; come ti dice apt-get i pacchetti in questione sono già installati.

mroghy
02-06-2012, 09:27
Io ho notato che quando esce un messaggio del genere da shell, devo fare l'aggiornamento da Gnome. Qualche volta funziona farlo da aptitude.
Sembra come che "xx non installati" voglia dire "xx si dovrebbero installare, ma non posso farlo io".
Sinceramente non ho capito niente sul perché ci sono tre sistemi per fare aggiornamenti, con apparentemente tre meccanismi diversi.

MItaly
02-06-2012, 10:06
Ma che c'entra? Se dai apt-get install lui cerca di installare il pacchetto che gli dici (build-essential o checkinstall), mica di aggiornare gli altri.
Per installare tutti gli aggiornamenti disponibili usa apt-get update (scarica la lista dei pacchetti aggiornata) e apt-get upgrade (installa gli aggiornamenti). Questo è esattamente equivalente ad installare gli aggiornamenti dal gestore di aggiornamenti di Gnome.

Se rimane roba da aggiornare, significa che ci sono degli aggiornamenti che richiedono una risoluzione delle dipendenze più complicata; per installarli, dai apt-get dist-upgrade (installa tutti gli aggiornamenti, risolvendo automaticamente eventuali problemi di dipendenze). In tal caso, prima di confermare controlla se per caso dice che per effettuare l'aggiornamento deve disinstallare roba, e in tal caso verifica se non si tratta di roba importante (non dovrebbe, ma non si sa mai).

Loading