PDA

Visualizza la versione completa : Alfa network sotto BackBox


pistilloi
10-06-2012, 13:27
Buon salve, di questi tempi non v'è tempo da perdere, quindi andiamo subito al tuorlo!

Come da titolo lavoro sotto BackBox Linux, kernel 2.6.38-15-generic-pae. Quando collego la scheda esterna "Alfa network AWUSO36H" il manager di rete grafico, mi risponde con: "rete senza fili (manufacturer realtek rtl8187 rtl8187 wireless) dispositivo non pronto". So per certo che la scheda funziona, poiché su Ubuntu 12.04 Precise, gira perfettamente.

I moduli rtl8187 sono installai perfettamente come si può osservare dal seguente output:


sinec@dante-HP-630-Notebook-PC:~$ sudo lsmod
Module Size Used by
rtl8187 55996 0
eeprom_93cx6 13134 1 rtl8187
binfmt_misc 13213 1
vboxnetadp 13323 0
vboxnetflt 27855 0
vboxdrv 219250 2 vboxnetadp,vboxnetflt
rfcomm 37332 8
bnep 17617 2
joydev 17322 0
parport_pc 32111 0
ppdev 12849 0
btusb 17911 0
snd_hda_codec_hdmi 27535 1
snd_hda_codec_realtek 255882 1
snd_hda_intel 28209 3
arc4 12473 4
snd_hda_codec 90901 3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_i ntel
ath3k 12786 0
snd_hwdep 13274 1 snd_hda_codec
snd_pcm 80042 3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
uvcvideo 66851 0
ath9k 115624 0
bluetooth 182891 25 rfcomm,bnep,btusb,ath3k
videodev 75143 1 uvcvideo
snd_seq_midi 13132 0
snd_rawmidi 25269 1 snd_seq_midi
mac80211 460893 2 rtl8187,ath9k
snd_seq_midi_event 14475 1 snd_seq_midi
snd_seq 51291 2 snd_seq_midi,snd_seq_midi_event
i915 451088 3
ath9k_common 13780 1 ath9k
ath9k_hw 379968 2 ath9k,ath9k_common
ath 19182 3 ath9k,ath9k_common,ath9k_hw
snd_timer 28659 2 snd_pcm,snd_seq
snd_seq_device 14110 3 snd_seq_midi,snd_rawmidi,snd_seq
hp_wmi 13418 0
drm_kms_helper 40971 1 i915
sparse_keymap 13666 1 hp_wmi
drm 184164 4 i915,drm_kms_helper
cfg80211 177896 4 rtl8187,ath9k,mac80211,ath
psmouse 59039 0
snd 55295 16 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_i ntel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,s nd_seq,snd_timer,snd_seq_device
rts_pstor 348243 0
soundcore 12600 1 snd
snd_page_alloc 14073 2 snd_hda_intel,snd_pcm
serio_raw 12990 0
compat 16044 11 rtl8187,rfcomm,bnep,btusb,ath3k,bluetooth,ath9k,ma c80211,ath9k_common,ath9k_hw,cfg80211
i2c_algo_bit 13184 1 i915
video 19112 1 i915
lp 13349 0
parport 36746 3 parport_pc,ppdev,lp
ahci 21591 2
r8169 46630 0
libahci 25548 1 ahci
sinec@dante-HP-630-Notebook-PC:~$

Quando cerco di mandare in up la scheda il sistema mi risponde con "argomento non valido":

sinec@dante-HP-630-Notebook-PC:~$ sudo ifconfig -a
eth0 Link encap:Ethernet HWaddr 9c:8e:99:41:46:e3
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisioni:0 txqueuelen:1000
Byte RX:0 (0.0 B) Byte TX:0 (0.0 B)
Interrupt:40

lo Link encap:Loopback locale
indirizzo inet:127.0.0.1 Maschera:255.0.0.0
indirizzo inet6: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:1633 errors:0 dropped:0 overruns:0 frame:0
TX packets:1633 errors:0 dropped:0 overruns:0 carrier:0
collisioni:0 txqueuelen:0
Byte RX:182341 (182.3 KB) Byte TX:182341 (182.3 KB)

vboxnet0 Link encap:Ethernet HWaddr 0a:00:27:00:00:00
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisioni:0 txqueuelen:1000
Byte RX:0 (0.0 B) Byte TX:0 (0.0 B)

wlan0 Link encap:Ethernet HWaddr 68:a3:c4:e1:76:ba
indirizzo inet:192.168.1.65 Bcast:192.168.1.255 Maschera:255.255.255.0
indirizzo inet6: fe80::6aa3:c4ff:fee1:76ba/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:28042 errors:0 dropped:0 overruns:0 frame:0
TX packets:26868 errors:0 dropped:0 overruns:0 carrier:0
collisioni:0 txqueuelen:1000
Byte RX:18639915 (18.6 MB) Byte TX:4565720 (4.5 MB)

wlan1 Link encap:Ethernet HWaddr 00:0f:04:b3:4d:76
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisioni:0 txqueuelen:1000
Byte RX:0 (0.0 B) Byte TX:0 (0.0 B)
sinec@dante-HP-630-Notebook-PC:~$
sinec@dante-HP-630-Notebook-PC:~$
sinec@dante-HP-630-Notebook-PC:~$ sudo ifconfig wlan1 up
SIOCSIFFLAGS: Argomento non valido
sinec@dante-HP-630-Notebook-PC:~$


ecco altri out che potrebbero esser utili per diagnosticare il problema:


sinec@dante-HP-630-Notebook-PC:~$ sudo lsusb
Bus 002 Device 023: ID 0bda:8187 Realtek Semiconductor Corp. RTL8187 Wireless Adapter
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 005: ID 0cf3:3005 Atheros Communications, Inc.
Bus 001 Device 003: ID 05c8:021e Cheng Uei Precision Industry Co., Ltd (Foxlink)
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
sinec@dante-HP-630-Notebook-PC:~$
sinec@dante-HP-630-Notebook-PC:~$
sinec@dante-HP-630-Notebook-PC:~$
sinec@dante-HP-630-Notebook-PC:~$ sudo lshw -c network
*-network
description: Ethernet interface
product: RTL8111/8168B PCI Express Gigabit Ethernet controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:01:00.0
logical name: eth0
version: 06
serial: 9c:8e:99:41:46:e3
size: 10Mbit/s
capacity: 1Gbit/s
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half latency=0 link=no multicast=yes port=MII speed=10Mbit/s
resources: irq:40 ioport:3000(size=256) memory:d0404000-d0404fff memory:d0400000-d0403fff
*-network
description: Wireless interface
product: AR9285 Wireless Network Adapter (PCI-Express)
vendor: Atheros Communications Inc.
physical id: 0
bus info: pci@0000:02:00.0
logical name: wlan0
version: 01
serial: 68:a3:c4:e1:76:ba
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=ath9k driverversion=2.6.38-15-generic-pae firmware=N/A ip=192.168.1.65 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
resources: irq:18 memory:d4400000-d440ffff
*-network DISABLED
description: Wireless interface
physical id: 2
bus info: usb@2:1.1
logical name: wlan1
serial: 00:0f:04:b3:4d:76
capabilities: ethernet physical wireless
configuration: broadcast=yes driver=rtl8187 driverversion=2.6.38-15-generic-pae firmware=N/A link=no multicast=yes wireless=IEEE 802.11bg
sinec@dante-HP-630-Notebook-PC:~$
sinec@dante-HP-630-Notebook-PC:~$
sinec@dante-HP-630-Notebook-PC:~$
sinec@dante-HP-630-Notebook-PC:~$ sudo iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:"Pace"
Mode:Managed Frequency:2.422 GHz Access Point: 00:90:D0:FB:67:1D
Bit Rate=54 Mb/s Tx-Power=16 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:2E9B-BC94-AC
Power Management:off
Link Quality=61/70 Signal level=-49 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:9 Invalid misc:38 Missed beacon:0

vboxnet0 no wireless extensions.

wlan1 IEEE 802.11bg ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:on

sinec@dante-HP-630-Notebook-PC:~$ sudo rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
1: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
15: phy14: Wireless LAN
Soft blocked: no
Hard blocked: no
sinec@dante-HP-630-Notebook-PC:~$ sudo dmesg |egrep -i "wlan1|not ready"
[ 12.097372] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 12.120198] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 5332.993370] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 5361.433029] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 7154.623246] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 7154.693216] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 7159.391438] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 7161.567798] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 7161.648810] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 7163.245632] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 7163.318457] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 7165.395585] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 7165.472564] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 7466.325400] <30>udev[3996]: renamed network interface wlan1 to wlan5
[ 7467.227193] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 7467.297727] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 7801.271024] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 7803.824585] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 7803.899555] ADDRCONF(NETDEV_UP): wlan0: link is not ready
sinec@dante-HP-630-Notebook-PC:~$

pistilloi
10-06-2012, 14:15
risolto, è stato sufficiente installare una versione più recente del kernel!

fivendra
11-06-2012, 10:54
bene :)

Loading