PDA

Visualizza la versione completa : Mandriva e Vpn Cisco


Akiro
11-07-2012, 12:19
Ciao a tutti,
ho un problema con la connessione di vpnc (vpnc-0.5.3-4mdv2010.1) su Mandriva (2010.2).

Utilizzando la scheda di rete (eth0) e lanciando il comando:

#vpnc vpnc.conf
il sistema mi restituisce:


Enter password for utente@server:
vpnc: receiving packet: No route to host

e su /var/log/messages logga:


Jul 11 11:50:07 host dhclient: Unsupported device type 65534 for "tun0"
Jul 11 11:50:07 host dhclient:
Jul 11 11:50:07 host dhclient: If you did not get this software from ftp.isc.org, please
Jul 11 11:50:07 host dhclient: get the latest from ftp.isc.org and install that before
Jul 11 11:50:07 host dhclient: requesting help.
Jul 11 11:50:07 host dhclient:
Jul 11 11:50:07 host dhclient: If you did get this software from ftp.isc.org and have not
Jul 11 11:50:07 host dhclient: yet read the README, please read it before requesting help.
Jul 11 11:50:07 host dhclient: If you intend to request help from the dhcp-server@isc.org
Jul 11 11:50:07 host dhclient: mailing list, please read the section on the README about
Jul 11 11:50:07 host dhclient: submitting bug reports and requests for help.
Jul 11 11:50:07 host dhclient:
Jul 11 11:50:07 host dhclient: Please do not under any circumstances send requests for
Jul 11 11:50:07 host dhclient: help directly to the authors of this software - please
Jul 11 11:50:07 host dhclient: send them to the appropriate mailing list as described in
Jul 11 11:50:07 host dhclient: the README file.
Jul 11 11:50:07 host dhclient:
Jul 11 11:50:07 host dhclient: exiting

mentre se uso vpnc con la connessione WIFI (wlan0) tutto fila liscio e riesco a connettermi alle macchine!


Ho provato anche a scaricarmi una delle ultime versioni di dhclient (dhcp-4.2.4.tar.gz) come consigliato dal messaggio, l'ho compilato ed ho fatto un link al nuovo dhclient (/usr/local/sbin/dhclient), ma il risultato non cambia ("vpnc: receiving packet: No route to host").

Ho provato anche da casa: mi collego al router con ip statico e da l in questo modo funziona... qui provando a mettere un ip statico non va...

Non so che altro provare.
Probabilmente qualche problema/bug di draknetcenter...

Akiro
31-07-2012, 10:55
Il colpevole netprofile che gestisce le postazioni di lavoro in modo INDEGNO, credo sia uno dei tool pi buggati della storia. :dh: :dh:
Ho dovuto confrontarmi un po' di file con kdiff3 di un paio di profili per notare che si porta dietro le vecchie configurazioni o comunque file e campi sporchi...

Forse ho risolto, peccato che non vi sia un alternativa a questo software.

Akiro
28-08-2012, 09:58
Alla fine non ho risolto.

Mi sembra di aver pulito il profilo in uso ma niente, sempre il solito errore!

Akiro
13-09-2012, 11:49
risolto definitivamente, son proprio pirla -___-''

Quando mi han dato il vpnc.conf non ho tenuto conto che l'IPSEC gateway era in forma di ip e non alias DNS...
mettendo l'alias funge anche con eth0!

Loading