PDA

Visualizza la versione completa : Gnuplot non plotta


xavier310
25-11-2012, 03:31
Salve ragazzi :smack: ho un piccolo problema con Gnuplot! Oggi ho reinstallato Ubuntu con la versione più recente, ma una volta quindi reinstallato Gnuplot non mi plotta più i grafici in automatico. Quale potrebbe essere il problema?

MItaly
25-11-2012, 15:02
Che comandi dai/che errori ti dà?

xavier310
25-11-2012, 16:05
Do comandi del tipo

plot "dati.dat" using 1:2

oppure

splot f(x)

e il bello che non mi da nessun errore, ma nemmeno nessun grafico

Probabilmente devo installare qualche pacchetto o qualche programma, ma non so quale. Qualche idea su come potrei risolvere il problema?

Ti ringrazio

MItaly
25-11-2012, 16:26
Quando apri gnuplot subito prima del prompt ci dovrebbe essere una riga "Terminal type set to 'wxt'", cosa c'è al posto di wxt nel tuo caso? Hai installato il pacchetto gnuplot-x11 o gnuplot-qt?

xavier310
25-11-2012, 16:46
Credo che non risultino installati perchè



G N U P L O T
Version 4.6 patchlevel 0 last modified 2012-03-04
Build System: Linux x86_64

Copyright (C) 1986-1993, 1998, 2004, 2007-2012
Thomas Williams, Colin Kelley and many others

gnuplot home: http://www.gnuplot.info
faq, bugs, etc: type "help FAQ"
immediate help: type "help" (plot window: hit 'h')

Terminal type set to 'unknown'

quindi il problema dovrebbe essere questo. Quele comando devo scrivere per installare i due pacchetti?

MItaly
25-11-2012, 19:15
sudo apt-get install gnuplot-x11

xavier310
26-11-2012, 01:43
Risolto! :D ti ringrazio molto

MItaly
26-11-2012, 01:48
:ciauz:

glcnrd
12-11-2016, 16:49
Ciao! Ho appena scaricato GNUPLOT ma non l'ho mai usato. Ho provato a segure le istruzioni ma...

gianluca@gianluca-HP-625:~$ sudo apt-get install gnuplot-x11
[sudo] password for gianluca:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
g++-4.7 libbackport-util-concurrent-java libcommons-codec-java libjaxme-java
libstdc++6-4.7-dev openjdk-7-jre-lib ttf-dejavu-extra
Usare "apt-get autoremove" per rimuoverli.
I seguenti pacchetti saranno inoltre installati:
libtiff5 libwxbase2.8-0 libwxgtk2.8-0
Pacchetti suggeriti:
gnuplot-doc
I seguenti pacchetti saranno RIMOSSI:
gnuplot-nox
I seguenti pacchetti NUOVI saranno installati:
gnuplot-x11 libwxbase2.8-0 libwxgtk2.8-0
I seguenti pacchetti saranno aggiornati:
libtiff5
1 aggiornati, 3 installati, 1 da rimuovere e 1493 non aggiornati.
E: Impossibile impostare il blocco /var/cache/apt/archives/lock - open (11: Risorsa temporaneamente non disponibile)
E: Impossibile bloccare la directory /var/cache/apt/archives/
Come posso fare?

sacarde
12-11-2016, 17:16
prova cosi' : http://chiedi.ubuntu-it.org/questions/6621/impossibile-impostare-il-blocco-varlibdpkglock

Loading