PDA

Visualizza la versione completa : aiuto installazione librerie


Kamui83
10-01-2013, 08:52
salve a tutti, sono nuovo al mondo linux ma devo utilizzarlo su un server e sto avendo un p di problemi nell'installare una libreria php.
sto usando putty per i comandi
quando eseguo la linea di codice
sudo apt-get install curl libcurl3 libcurl3-dev php5-curl
mi dice

Err http://debian.fastweb.it lenny/main libssl0.9.8 0.9.8g-15+lenny16 404 Not Found

Failed to fetch http://debian.fastweb.it/debian/poo...nny16_amd64.deb 404 Not Found
ho provato a cambiare il server nel sources.list aggiungendo come repository http://archive.debian.org/debian/ ma mi restituisce
E: Couldn't find package php5-curl
come faccio ad installare la libreria? non riuscendoci tramite comando possibile fare direttamente l'upload dei file? se si trovo qualche guida su dove mettere mano?

sacarde
10-01-2013, 10:21
mi dicono che la "old stable" (lenny) non e' piu supportata

gli errori sono che non trova piu i repo



- per cercare: apt-cache search php5-curl

- per cercare nel web: http://www.debian.org/distrib/packages


aspetta qualche esperto debian, forse c'e' qualche altro modo per installarci

Kamui83
10-01-2013, 10:30
Originariamente inviato da sacarde
mi dicono che la "old stable" (lenny) non e' piu supportata

gli errori sono che non trova piu i repo



- per cercare: apt-cache search php5-curl

- per cercare nel web: http://www.debian.org/distrib/packages


aspetta qualche esperto debian, forse c'e' qualche altro modo per installarci
ma nel repository che ho usato dal web lo vedo, dovrebbe esserci
facendo apt-cache search php5-curl mi dice php5-curl - CURL module for php5 , ma non so cosa significhi :(

sacarde
10-01-2013, 10:39
se lo vedi, dovrebbe esserci...


hai sincronizzato gli indici?

apt-get update

e poi:

apt-get install php5-curl



p.s.
controlla i repo della old-stable
http://guide.debianizzati.org/index.php/Repository_ufficiali#Oldstable_.28la_vecchia_stabl e.29:_Debian_Lenny

Kamui83
10-01-2013, 10:49
Originariamente inviato da sacarde
se lo vedi, dovrebbe esserci...


hai sincronizzato gli indici?

apt-get update

e poi:

apt-get install php5-curl



p.s.
controlla i repo della old-stable
http://guide.debianizzati.org/index.php/Repository_ufficiali#Oldstable_.28la_vecchia_stabl e.29:_Debian_Lenny
grazie mille, fatto l'update e ha funzionato :)

Loading