PDA

Visualizza la versione completa : apache2, Forbidden


PiHeich
03-08-2013, 21:20
Salve, ho installato apache2 su l'ultimo ubuntu. Provando l'index.html funziona. Ho cambiato i permessi alla cartella var/www con

sudo chmod 777 -R www
e ho messo un mio file "index.php"(che su windows 8 con installato wamp funziona..) e mi esce la scritta
Forbidden You don't have permission to access .... on this server

A questo punto ho cercato delle soluzioni, senza successo, cambiando nel file /etc/apache2/sites-enabled/000-default tutto quello che era "None" con "All"

Qualcuno sa il motivo? Come posso risolvere?

Esiste qualcosa di analogo ad apache2 e pių leggero per caso?


Grazie mille.








Ps. come mai in ambiente linux tutto diventa pių complicato???? :prrr:

Lucania
05-08-2013, 16:52
Ciao, hai installato php e il modulo php per Apache? Inoltre cambiare tutto da "None" a "All" potrebbe peggiorare la situazione perchč se l'ultima direttiva presa in considerazione da Apache č Deny, ti ritroveresti con un bel "Nega l'accesso a chiunque".

Loading