PDA

Visualizza la versione completa : [vb][Excel] Formule..


Gigi84
26-07-2002, 09:21
Ciao a tutti!!

la questione giornaliera è la seguente..

Devo scrivere in una cella una semplice formula:
del tipo SOMMA, solo che per definire una cella non voglio utilizzare il formtato A1 o B4, ma i numeri (riga,colonna) è possibile???

se volessi fare =SOMMA(A1:A4) come faccio a "tradurlo"????
..si può vero..?:sgrat:



:ciauz: :ciauz:

Gigi84
26-07-2002, 11:00
nn si può davvero..???? :sgrat: :sgrat: :sgrat:

:ciauz: :ciauz:

IlGrandeReddy
26-07-2002, 11:16
Non ho capito il tuo italiano........ :gren:

mi rispieghi il problema? vuoi cambiare i nomi delle celle da X9 a (x,9)??

Qualcosa si può fare, impostando delle riga di intestazione della tabella e colonna di intestazione della tabella con i valori che diventeranno i tuoi riferimenti e poi usando formule ricerca e riferimento (cerca verticale/orizzontale, indice, riferimento) ma fatto questo il file aumenta considerevolmente le sue dimensioni e il tutto si fa più complesso.....

cerca di postare un esempio e vediamo.

ciau

Drocchia
26-07-2002, 11:17
:master: Scusa ma nn va bene come hai detto te??!!


=SOMMA(A1:A4) come faccio a "tradurlo"????

Gigi84
26-07-2002, 11:42
Allora, in Excel per fare riferimento alle celle si fa
A1 --> è la cella che è in riga 1, colonna 1

D3 --> riga 3, colonna 4

F2 --> riga 2, colonna 6

io da VB non voglio utilizzare una lettera per definire la colonna!!!
infatti la definisco tramite i numeri delle colonna e della riga:

cella "A1" = Worksheet.cells (1,1)

domanda: in una formula posso fare riferimento ad una cella identificandola tramite numeroriga e numerocolonna???

=SOMMA(A1:A4) vorrei che diventasse
=SOMMA(Cella(1,1):Cella(4,1))

Spero di essermi spiegato..:gren:

:ciauz: :ciauz:

darkblOOd
26-07-2002, 11:46
certo che si può:



xlWorkSheet.Cells(x, y) = "=sum(...)"


:ciauz:

Gigi84
26-07-2002, 12:00
ecco.. ma dentro sum(???)

cosa ci metto??? ricorda che le celle voglio identificarle tramite la riga e la colonna.. quindi senza usare le lettere! (la colonna voglio identificarla tramite il numero di colonnae non la lettera!)

dai che forse ci siamo!!



:ciauz:

darkblOOd
26-07-2002, 12:06
Originariamente inviato da Gigi84
ecco.. ma dentro sum(???)

cosa ci metto??? ricorda che le celle voglio identificarle tramite la riga e la colonna.. quindi senza usare le lettere! (la colonna voglio identificarla tramite il numero di colonnae non la lettera!)

dai che forse ci siamo!!



:ciauz:

non mi dire che non sai concatenare una stringa :dottò:



xlWorkSheet.Cells(x, y) = "=sum(" & xlWorkSheet.Cells(x, y) & ":" & xlWorkSheet.Cells(x, y) & ")"

Gigi84
26-07-2002, 12:11
nono!



xlWorkSheet.Cells(x, y) = "=sum(" & xlWorkSheet.Cells(x, y) & ":" & xlWorkSheet.Cells(x, y) & ")"


se faccio così dentro sum mi mette i valori delle celle..
in sintesi io voglio poter fare riferimeto alla colonna senza usare la lettera che la identifica ma usando il numero della colonna.. si può?


scusate l'italiano ma.. mi esce coì..:gren:


:ciauz: :ciauz:

darkblOOd
26-07-2002, 12:22
Originariamente inviato da Gigi84
nono!



xlWorkSheet.Cells(x, y) = "=sum(" & xlWorkSheet.Cells(x, y) & ":" & xlWorkSheet.Cells(x, y) & ")"


se faccio così dentro sum mi mette i valori delle celle..
in sintesi io voglio poter fare riferimeto alla colonna senza usare la lettera che la identifica ma usando il numero della colonna.. si può?


scusate l'italiano ma.. mi esce coì..:gren:


:ciauz: :ciauz:
scusa, ma qual'è il tuo problema?

così non ti piace?


xlWorkSheet.Cells(x, y) = "=sum(A" & x & ":A" & y & ")"


Perchè non vuoi mettere le lettere? In excel devi specificare le coordinate della cella interessata e tali coordinate sono espresse con LETTERA x la colonna e NUMERO per la riga.


:bubu:

Loading