PDA

Visualizza la versione completa : Rete Lan fra due pc: Windows 8.1 e Windows xp (Sp3), problema Ip e Gateway


Rocquero
11-01-2014, 17:30
Ciao,

vorrei creare una semplice LAN casalinga fra due pc. Solo che già quando vado a controllare se il ping funziona su entrambi la cosa non riesce, nel senso, pc1 pinga perfettamente pc2 mentre non avviene il viceversa dove mi dice che la Rete di destinazione è irraggiungibile.

Ora, non sapendo bene come andrebbero configurati gli indirizzi ip, non so purtroppo come agire.

La situazione è la seguente:

Pc1 - Windows 8.1 (nuovo) connesso Wifi ad un Router Belkin connesso via cavo al Modem Tele2 (che pinga perfettamente pc2)
Nome=Notebook
Ip=192.168.2.6
Subnet mask=255.255.255.0
Gateway predefinito=192.168.2.1

Pc2 - Windows xp (sp3) (il pc vecchio) connesso tramite cavo ethernet direttamente al Modem Tele2 (che invece non vede il pc1)
Nome=Desktop
Ip=192.168.1.3
Subnet mask=255.255.255.0
Gateway predefinito=192.168.1.254

Su entrambi i pc ho impostato già alcune condivisioni di cartelle. Entrambi i pc non vedono nulla dell'altro. Però con un terzo pc che ora non è in considerazione che monda Windows7 riesco a vedere il WORKGROUP del pc1 senza nessun problema e anzi senza aver operato su nulla.

La mie domande, da ignorante in materia, sono:
è giusto che i 2 pc avendo scheda rete e modalità differente di accesso ad internet abbiano indirizzi gateway differenti?
sono effettivamente differenti i due gateway perché l'uno è connesso al router e l'altro al modem?
dato che fisicamente sono connessi in "cascata" può essere questo il motivo per cui pc2 non vede pc1?
c'è un modo per risalire fino a pc1?

I DNS Server in ambo le macchine sono uguali al gateway predefinito. Deve essere così? E' una regola?

Altra cosa solo per chiarimento, ho letto che gli Ip di tipo C, da 192.nnn.nnn.xxx in poi, hanno la stessa base "n" in comune è corretto? Per intenderci credo di aver capito che non si possa mettere un gateway con 192.168.2.xxx ed un ip 192.168.1.xxx sulla stessa macchina, ad esempio. giusto?

Ho provato anche a fare un pò di prove cambiando indirizzi ip e gateway ma nel momento in cui agisco perdo anche le connessioni ad internet, così ho riimpostato tutto come prima ed ora mi appello al responso degli esperti. :D

Ringrazio in anticipo delle risposte.

fivendra
11-01-2014, 21:16
La rete deve avere la stessa classe ip, per quello hai problemi.

Rocquero
11-01-2014, 21:32
La rete deve avere la stessa classe ip, per quello hai problemi.

Non sono tutti gli indirizzi (compresi i gateway) di Classe C? e nel caso come faccio a modificarli e come?

fivendra
11-01-2014, 21:56
Devi utilizzare o tutti 192.168.1.xxx o 192.168.2.xxx

Rocquero
11-01-2014, 22:26
Devi utilizzare o tutti 192.168.1.xxx o 192.168.2.xxx

Avevo già provato a cambiare da Risorse di Rete gli indirizzi del pc2 (quello collegato direttamente al modem) impostando ad esempio:

Ip: 192.168.2.10
Gateway: 192.168.2.1 (uguale all'indirizzo gateway del pc1) oppure
192.168.2.2 (diverso indirizzo gateway ma sempre su xxx.xxx.2.xxx)


ma se provo a fare una cosa del genere non mi si connette neanche più ad internet.

Da quel che ho pensato io (correggetemi se sbaglio): avendo una rete così impostata:

pc1 --> router --> modem <-- pc2

il router abbia un suo indirizzo che è 192.168.2.xxx
mentre il modem 192.168.1.xxx

sbaglio? e come configuro in effetti una rete del genere? :spy:

fivendra
11-01-2014, 22:32
Tutti i dispositivi, router compresi, all'interno della stessa rete devo avere la medesima classe ip. I computer mettili entrambi dietro il router.

Rocquero
12-01-2014, 03:39
Tutti i dispositivi, router compresi, all'interno della stessa rete devo avere la medesima classe ip. I computer mettili entrambi dietro il router.

Allora, ho fatto svariate prove modificando gli ip sia del modem che del router che dei pc a esso connessi.

Volevo avere tutto bene ordinato su 192.168.1.xxx come mi hai consigliato e ho messo, ad esempio:
modem xxx.xxx.1.1 <-- pc connesso al modem xxx.xxx.1.3
router xxx.xxx.1.2 (connesso al modem) <-- pc connesso al modem xxx.xxx.1.4

ma si verifica in questa condizione che il pc del modem si connette ad internet mentre il pc del router e il router stesso non possono in alcun modo accedere alla connessione internet. La situazione ritorna alla normalità solamente se router e modem si trovano su due classi ip differenti (xxx.xxx.a.xxx e xxx.xxx.b.xxx per intenderci).. c'è un motivo specifico perché io non riesca a cambiare questa situazione ponendo tutto in xxx.xxx.1.xxx?

Ho anche provato come mi hai consigliato a mettere entrambi i pc dietro al router ma come conseguenza la linea era estremamente rallentata, cosa che non avviene mai col pc attaccato al modem. Motivo per cui vorrei cercare di sistemare la situazione attuale così com'è giostrando sugli ip e magari i permessi di accesso all'uno o all'altro dispositivo.

Hai qualche altro consiglio/suggerimento da darmi a riguardo? thanks..

br1
12-01-2014, 09:39
Prova mettendo gli ip come prima e impostando la subnet mask per tutti i dispositivi a 255.255.0.0

Rocquero
12-01-2014, 12:09
Prova mettendo gli ip come prima e impostando la subnet mask per tutti i dispositivi a 255.255.0.0

Mi permette di impostare la subnet mask solamente nel modem a 255.255.0.0, cosa che cmq non permette al pc xxx.xxx.1.2 di raggiungere nulla che sia xxx.xxx.2.xxx..

Invece se provo a cambiare la subnet mask nel router ottengo:

"La pagina all'indirizzo 192.168.2.1 dice:

Formato non valido, la maschera di rete deve essere 255.255.255.0 oppure 255.255.255.128
oppure 255.255.255.192 oppure 255.255.255.224 oppure 255.255.255.240
oppure 255.255.255.248 oppure 225.255.255.252 oppure 255.255.255.254

Sbaglio o mi sta dicendo il router che non mi permette di entrare nella classe B?

Penso: non è che il router ha qualche restrizione che chiude cioè che viene dall'esterno modem compreso? mentre il modem è più libero?

Inoltre, se anche riesco a permettere agli ip xxx.xxx.1.xxx di vedere quelli con xxx.xxx.2.xxx potrò in quel caso comunque costruire la Lan? o come si diceva prima:


Tutti i dispositivi, router compresi, all'interno della stessa rete devo avere la medesima classe ip. I computer mettili entrambi dietro il router.

br1
12-01-2014, 15:55
EDIT

... la tua ultima domanda non l'ho capita :fagiano:

Loading