PDA

Visualizza la versione completa : debian testing: cambiato system manager


magnet_80
07-07-2014, 14:14
ciao a tutti.
ho la debian testing+kde. ieri sera, ho dovuto ripristinare il pc al backup completo, effettuato con clonezilla, di fine maggio.
ho aggiornato tutto e ho notato che è stato rimosso il pacchetto "sysvinit-core" e mi è stato aggiunto al suo posto il pacchetto "systemd-sysv".
ora, in fase di boot/reboot/shutdown, non vedo più a video i vari log.
aggiungo che, fino agli aggiornamenti del 30 giugno i log venivano presentati. molto probabilemnte c'era ancora installato "sysvinit-core".
se cerco di rimuovere "systemd-sysv" e mettere al suo posto "sysvinit-core", synaptic mi segnala che deve rimuovere alcuni pacchetti di kde (kde-full, kde-standard) e altri ancora.
ho quindi lasciato installato "systemd-sysv".
domanda: qualcuno ha avuto il mio stesso problema? conviene tenere "systemd-sysv"? soluzione per far presentare ancora i log?
grazie

sacarde
07-07-2014, 16:51
e' una gestione nuova dei processi di inizializzazione

non ho capito quali log dici,
quelli con gli : [OK] per ogni servizio/funzione?

ci sono anche con systemd
comunque per vedere i log : journalctl -b
per vedere i servizi avviati: systemctl list-unit-files

(i primi tempi non e' un semplice passaggio eh!)

https://wiki.debian.org/systemd
http://www.freedesktop.org/wiki/Software/systemd/
https://medium.com/@johannes_gehrs/getting-started-with-systemd-on-debian-jessie-e024758ca63d

magnet_80
07-07-2014, 21:42
e' una gestione nuova dei processi di inizializzazione
non ho capito quali log dici,
quelli con gli : [OK] per ogni servizio/funzione?
sì esatto, quelli con [OK] c'è un modo per farli "ricomparire"? mi mancano..... :(
altra cosa: essendo una gestione nuova, mi pare di aver capito che prenderà il posto di "sysvinit-core". corretto?
grazie.

edit: ora non riesco a vedere se ho anche installato il pacchetto "systemd-sysv"

sacarde
07-07-2014, 22:02
- dal grub, hai passato al kernel dei parametri tipo: quiet ?
provato a premere "esc" al boot

- ma dici da: dpkg -l | grep systemd

magnet_80
07-07-2014, 22:29
ti rispondo solo a una parte, il resto, te lo posso dire domani sera.
- dal grub, hai passato al kernel dei parametri tipo: quiet ?
no, perchè ha fatto tutto synaptic. non mi sono accorto di nulla, di solito ci butto l'occhio per vedere gli aggiornamenti nuovi. ho lanciato l'update (dato che il ripristino era del 25 maggio) e l'ho lasciato andare. erano più di 500 pacchetti. mea culpa

sacarde
08-07-2014, 09:03
beh controlla sulla riga del kernel

ma al posto della lista dei servizi... cosa vedi?

magnet_80
08-07-2014, 19:03
output di dpkg -l | grep systemd
ii libpam-systemd:amd64 204-14 amd64 system and service manager - PAM module
ii libsystemd-daemon0:amd64 204-14 amd64 systemd utility library
ii libsystemd-id128-0:amd64 204-14 amd64 systemd 128 bit ID utility library
ii libsystemd-journal0:amd64 204-14 amd64 systemd journal utility library
ii libsystemd-login0:amd64 204-14 amd64 systemd login utility library
ii systemd 204-14 amd64 system and service manager
ii systemd-sysv 204-14 amd64 system and service manager - SysV links
ii systemd-ui 3-2 amd64 graphical frontend for systemd

provato a premere "esc" al boot
si, ma non fa nulla.
hai passato al kernel dei parametri tipo: quiet ?
come faccio a vederlo?

sacarde
08-07-2014, 20:15
- i pacchetti li hai entrambi:
systemd e systemd-sysv



- non ho capito cosa vedi al boot?



gli argomenti passati al kernel li vedi:

- da grub1 in: /boot/grub/menu.lst
- da grub2 in: /etc/default/grub

magnet_80
08-07-2014, 21:24
al boot vedo solamente che fa il clean dei file (lo faceva anche prima) e poi basta. la schermata rimane li ferma finchè non parte kde. prima invece, dopo il clean dei file, mostrava i log di sistema
qui /etc/default/grub


# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'
GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""
# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"
# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console
# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480
# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true
# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"
# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

kernel: 3.14.9-1-amd64 su debian 64bit
c'è solo lui installato

sacarde
08-07-2014, 22:04
modifica il file /etc/default/grub

togli il: quiet

e esegui:

sudo update-grub

Loading