PDA

Visualizza la versione completa : Problema grave con scheda di rete


Virgilio_x
19-01-2015, 09:04
Qualche giorno fa ho trovato il PC (con kubuntu) bloccato con le luci della tastiera che lampeggiavano, sono stato costretto ad un arresto del PC tenendo premuto il pulsante di accensione. Al riavvio la macchina non si riavviava e presentava un problema relativo a initramfs.
Facendo qualche ricerca sono riuscito a risolverlo avviando il pc da una distro live e facendo il controllo del disco (e sistemazione) dell'HD.

Però adesso quando riavvio non si connette più la scheda di rete, il led è spento.
Pensando ad un malfunzionamento della scheda di rete (integrata sulla piastra madre) ne ho acquistato una pciexpress aggiuntiva e l'ho installata ma non funziona nemmeno quella.

Mi sa che la sistemazione del disco ha compromesso la connessione di rete.

Come posso risolvere?

sacarde
19-01-2015, 16:24
vedi errori dal comando: dmesg | grep eth
?


che vedi dal comando: lspci

Virgilio_x
20-01-2015, 09:21
Ecco cosa mi ritorna con dmesg | grep eth
[ 0.890638] r8169 0000:03:00.0: eth0: RTL8168e/8111e at 0xffffc90000646000, e8:de:27:a7:92:3c, XID 0c200000 IRQ 44
[ 0.890641] r8169 0000:03:00.0: eth0: jumbo features [frames: 9200 bytes, tx checksumming: ko]
[ 1.212929] e1000e 0000:00:19.0: eth1: (PCI Express:2.5GT/s:Width x1) c8:9c:dc:6c:26:0f
[ 1.212931] e1000e 0000:00:19.0: eth1: Intel(R) PRO/1000 Network Connection
[ 1.212963] e1000e 0000:00:19.0: eth1: MAC: 10, PHY: 11, PBA No: FFFFFF-0FF
[ 18.188575] udevd[628]: renamed network interface eth0 to rename2
[ 18.205367] udevd[661]: renamed network interface eth1 to eth0
[ 18.252389] udevd[628]: renamed network interface rename2 to eth1
[ 22.088362] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 22.427825] r8169 0000:03:00.0: eth1: link down
[ 22.427843] r8169 0000:03:00.0: eth1: link down
[ 22.428092] ADDRCONF(NETDEV_UP): eth1: link is not ready
[ 56.840461] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 56.987694] r8169 0000:03:00.0: eth1: link down
[ 56.988047] ADDRCONF(NETDEV_UP): eth1: link is not ready


lspci mi ritorna
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:19.0 Ethernet controller: Intel Corporation 82579V Gigabit Network Connection (rev 05)
00:1a.0 USB Controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
00:1c.4 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 5 (rev b5)
00:1d.0 USB Controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation H61 Express Chipset Family LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
01:00.0 VGA compatible controller: nVidia Corporation Device 0de5 (rev a1)
01:00.1 Audio device: nVidia Corporation GF108 High Definition Audio Controller (rev a1)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)

sacarde
20-01-2015, 10:01
quali dispositivi vedi dal comando: ip a
oppure da: ifconfig -a


prova a collegarli, uno a uno, in rete (dhcp) a mano:

sudo dhclient <dispositivo>

esempio:

sudo dhclient eth0

Virgilio_x
20-01-2015, 10:43
quali dispositivi vedi dal comando: ip a
oppure da: ifconfig -a


prova a collegarli, uno a uno, in rete (dhcp) a mano:

sudo dhclient <dispositivo>

esempio:

sudo dhclient eth0

i dispositivi che vedo sono eth0, eth1 e poi lo (local host).
se provo a digitare
sudo dhclient eth0
oppure
sudo dhclient eth1
non succede nulla, il cursore si ferma sotto la riga e resta li in attesa all'infinito...

sacarde
20-01-2015, 10:46
ma hai un router con il dhcp attivo?

Virgilio_x
20-01-2015, 10:52
Si.
Per gli altri PC ed il server nessuna anomalia, dunque escludo che il problema sia a livello di router

sacarde
20-01-2015, 11:50
qui risolvono con:


ethtool -s eth0 autoneg off speed 100 duplex full


http://forum.ubuntu-it.org/viewtopic.php?p=4373545

che versione di kubuntu ?





p.s.
- durante il controllo fsck hai notato file che davano errore?

potresti:
- rieseguire un fsck della partizione
- reinstallare i pacchetti relativi alla rete

Virgilio_x
21-01-2015, 10:55
qui risolvono con:


ethtool -s eth0 autoneg off speed 100 duplex full


http://forum.ubuntu-it.org/viewtopic.php?p=4373545

che versione di kubuntu ?





p.s.
- durante il controllo fsck hai notato file che davano errore?

potresti:
- rieseguire un fsck della partizione
- reinstallare i pacchetti relativi alla rete

il pacchetto ethtool non è installato. Ho fatto il download del pacchetto deb da un altro pc, l'ho trasferito su quel pc ma non parte l'installazione. Evidentemente la versione di kubuntu del pc è troppo datata.

Il controllo fsck l'ho eseguito 2-3 volte quando ho dovuto ripristinare, proprio per essere sicuro che avesse corretto tutto.

Reinstallare i pacchetti della rete è un problema per la versione un po' datata.

Era previsto una reinstallazione di kubuntu verso marzo/aprile ma mi sa che devo farla prima...

Vorrei essere però sicuro di non reinstallare su un HD danneggiato. Il tool di controllo del disco che c'è di solito sui CD delle distro sono affidabili? Quando ci mettono a controllare l'intero HD?

sacarde
21-01-2015, 11:07
- se usi una live... le schede di rete funzionano?

- speravo di trovare i pacchetti nella cache di apt

- i controlli si basano, anche se fatti da gparted, su fsck
dipendono dalle dimensioni della partizione

- per installare il pacchetto:
sudo dpkg -i <nomepacchetto.deb>

- per vedere che versione hai di kubuntu: lsb_release -a

Loading