PDA

Visualizza la versione completa : Aggiornamento Ubuntu Server e problemi Apache


flower
25-06-2015, 13:26
Buongiorno,
ho aggiornato la mia versione di Ubuntu Server dalla versione13.10 alla versione 14.04. Con l'aggiornamento di versione stata aggiornata anche la versione di Apache che passata dalla versione 2.2 alla versione 2.4. Sembra tutto OK per il resto ma non riesco a far funzionare il web server Apache.


Versione di Apache aggiornata:

Server version: Apache/2.4.7 (Ubuntu)
Server built: Mar 10 2015 13:05:59


L'errore generato il seguente:

apache2: Syntax error on line 210 of /etc/apache2/apache2.conf: Could not open configuration file /etc/apache2/mods-enabled/authz_default.load: No such file or directory
Action 'configtest' failed.
The Apache error log may have more information.
...fail!


La riga 210 del file "/etc/apache2/apache2.conf" la seguente:

Include mod-enabled/*.load


Aggiungo che la macchina viene utilizzata come Server NAGIOS.
Qualcuno mi sa aiutare a sistemare?

sacarde
25-06-2015, 18:26
non ho capito bene...

hai il file:
/usr/lib/apache2/modules/mod_authz_default.so

ma non il file:
/etc/apache2/mods-enabled/authz_default.load


?


p.s.
il log degli errori:
/var/log/apache2/error.log

pilovis
22-07-2015, 09:59
Gli aggiornamenti di Linux sono trappole piene di insidie, soprattuto il passaggio tra releases diverse.
Sembra che nella comunita' linux la parola "compatibilita' con il passato" non esista, gli sviluppatori modificano i percorsi dei files di configurazione con una facilita' disarmante :jam:
E' questo che mi fa incazzare di piu':nillio:

Guarda questo esempio, addirittura nella stessa release un giorno si sono svegliati e in un aggiornamento hanno cambiato i files di configurazione di apache, come se nulla fosse:
http://forum.html.it/forum/showthread.php?threadid=1019664&pagenumber=40
http://forum.html.it/forum/showthread.php?threadid=1019664&pagenumber=41

Comunque quando si fa un server non si dovrebbe mai fare cambi di releases, soprattutto su un server di produzione.
Meglio rifare il server da capo con la nuova versione, testarlo e poi metterlo al posto del vecchio.

Loading