PDA

Visualizza la versione completa : Installazione di Scrapy per Python 3.4


FrancescoDV0695
16-09-2015, 22:49
Ciao a tutti ragazzi,
č da un paio di mesi che mi sono messo a studiare il linguaggio di programmazione Python. Mentre studiavo tra una guida trova online ed un'altra, mi sono imbattuto in Scrapy " A Fast and Powerful Scraping and Web Crawling ...". Incuriosito dalla cosa, l'ho scaricato ed ho successivamente provato ad installarlo. Inizialmente quando provavo ad installare Scrapy dalla prompt comandi mi usciva "microsoft visual c++ 10.0 is required (unable to find vcvarsall.bat)", ma questo intoppo sono riuscito a risolverlo eseguendo GCC (GNU Compiler Collection). Dopo ciņ ho riprovato ad installare Scrapy ed ecco cosa mi esce fuori ora:

if self.ld_version >= "2.10.90":

TypeError: unorderable types: NoneType() >= str()


----------------------------------------
Command "C:\Python34\python.exe -c "import setuptools, tokenize;__file__='C:\\Users\\FRANCE~1\\AppData\\L ocal\\Temp\\pip-build-y0qxqhwg\\lxml\\setup.py';exec(compile(getattr(tok enize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record C:\Users\FRANCE~1\AppData\Local\Temp\pip-4iysh0ta-record\install-record.txt --single-version-externally-managed --compile" failed with error code 1 in C:\Users\FRANCE~1\AppData\Local\Temp\pip-build-y0qxqhwg\lxml


Potreste darmi qualche consiglio su come risolvere questo problema?

Loading