PDA

Visualizza la versione completa : [C++] Errore "Please install v140_xp build tools" in Visual Studio


zacca94
14-04-2018, 14:53
Errore completo:

Severity Code Description Project File Line Suppression State
Error MSB8020 The build tools for v140_xp (Platform Toolset = 'v140_xp') cannot be found. To build using the v140_xp build tools, please install v140_xp build tools. Alternatively, you may upgrade to the current Visual Studio tools by selecting the Project menu or right-click the solution, and then selecting "Retarget solution".
C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets\Mic rosoft.Cpp.Platform.targets 57


Vorrei provare anche: Alternatively, you may upgrade to the current Visual Studio tools by selecting the Project menu or right-click the solution, and then selecting "Retarget solution"

Solo che cliccando col destro sul progettom facendo "retarget" e poi "build" sul progetto che ha bisogno del vecchio platform toolset non va comunque

In caso, come installo il platform toolset del vs 2015?

oregon
14-04-2018, 15:09
Nelle ProprietÓ del progetto, Configurazione -> Generale, visualizza l'elenco dei Platform Toolset disponibili e utilizza la v141 (per il 2017)

zacca94
14-04-2018, 15:12
Ci sono andato e non ne ho eccetto quella di default

oregon
14-04-2018, 15:19
La situazione qual Ŕ?

Avevi un progetto 2015 e lo hai aperto con il 2017? Hai fatto la conversione alla prima apertura?

Loading