PDA

Visualizza la versione completa : 'errore non specificato'


mvent
29-08-2002, 17:17
ho un sito (fatto con le webclass [visual basic 6.0]) al cui interno sono presenti collegamenti a database tramite ADO.

la situazione č questa :
se dopo aver riavviato il computer lancio il programma da visual basic , funziona tutto.

se invece lo compilo, creo il pacchetto di installazione, (creando quindi tralaltro un file ASP e una DLL), e lo faccio partire da internet explorer, ogni volta che utilizzo una procedura che si connette al database, mi da l'errore :

'errore non specificato'

si verifica ogni volta che provo a connettermi al database.
(cioč sul 99,8 % delle procedure del programma)

qualcuno sa darmi una spiegazione ??

info : io uso
-access 2000
-windows 2000
-connessioni al database tramite ADO
-la versione del MDAC č la 2.7
-internet explorer 6


:eek:

mvent
29-08-2002, 17:55
...possa aiutarmi ??

:eek:

Joda
30-08-2002, 09:10
sul probelam della connessione in VB6 dovrebbe esserci qualcosa nel forum verifica, in questo momento nn ricordo esattamente dove.

:quipy:

mvent
30-08-2002, 10:19
ho fatto una ricerca su tutti i forum della stringa 'errore non specificato'.

ho trovato tra i tanti messaggi qualcosa che si avvicinava al mio problema, ho provato ad applicare quelle soluzioni, ma non č servito a niente (tranne che a sapere che il mio problema non si risolve in quel modo).

comunque questa che mi succede č davvero strana.

ho cercato anche nella Knowledge Base della Microsoft, nei newsgroup di visual basic e altri linguaggi, ma andata come sopra.

non sono neanche sicuro che questo errore viene generato quando mi connetto al database.
ad esempio ho fatto in ogni routine che quando si verifica un errore
attraverso l'ON ERROR lo mando ad una procedura unica di gestione degli errori.

bč , succede che fissando dei punti di interruzione all'iinizio della routine di gestione degli errori, ma anche in qualsiasi altra routine,
il programma non ci passa mai.
eppure quando lancio il programma , clicco su una qualsiasi procedura,
mi visualizza l'errore 'errore non specificato' con la stessa formattazione che gli do nella mia routine di gestione degli errori, cosa impossibile perchč il programma non ci passa.

non me lo so proprio spiegare.

penso che con molta probabilitŕ dipenda da qualche incomprensione tra internet information services e windows.


mah...


:eek:

Joda
30-08-2002, 12:37
prova acercare nel forum problema connessione con VB6...

:tongue:

mvent
30-08-2002, 15:27
fatto anche questo.

ancora non funge


(grazie comunque per l'aiuto)

:mavieni:

Loading