PDA

Visualizza la versione completa : ACCESS non elimina i record?!?


l'evangelista
19-09-2002, 09:50
Ciao a tutti

ho questo problema con ACCESS

-Ho un db con una tabella "utenti"
-Elimino quasi tutti i record
-Quando la riapro ritrovo tutti i record (tranne quei 3 o 4 che non avevo eliminato) con scritto in tutti i campi "#Eliminato#"

Perchè non li cancella definitivamente ?? :confused:

Se può entrarci qualcosa, accedo al db, oltre che "manualmente", anche via codice COLD FUSION (server installato in locale), ma da li non ho mai cancellato record.

Grazie a tutti! :) :)

al79it
19-09-2002, 12:23
generalmente la scritta eliminato scompare dopo qualche secondo, penso tu abbia aperto la tabella troppo rapidamente.
D'altra parte se avessi altre tabelle relazionate a quella da cui elimini record non ti permetterebbe nemmeneo di cancellare i record..
Forse non ho ben capito il vero problema!!
In bocca al lupo
AL

alka
19-09-2002, 12:45
Nella mia esperienza, una cosa simile mi succedeva quando aprivo una tabella dati ed eseguivo contemporaneamente una query di eliminazione: tutti i campi della visualizzazione a tabella relativi ai record eliminati venivano contrassegnati con #Eliminato#.

Bastava chiudere e riaprire la tabella per vedere la situazione aggiornata. Credo che fosse solo un espediente di visualizzazione, poichè i record venivano effettivamente eliminati.

Ciao! :ciauz:

l'evangelista
19-09-2002, 14:34
Grazie per le risposte.

Purtroppo è un caso strano..
io elimino i record (che non hanno alcuna relazione con altre tabelle), poi riapro la tabella (non è una questione di "rapidità", il problema sussiste anche se la riapro dopo 2 ore, o il giorno dopo..) e mi trovo tutti questi "#Eliminato#"....

una cosa del genere mi era capitata solo quando, come diceva al, eliminavo record da una query tenendo magari la tabella (o una maschera soprastante) aperta...

ma questa è una situazione nuova :confused: :confused:

Loading