PDA

Visualizza la versione completa : Vb e SqlServer


Mr.E
04-10-2002, 10:30
Ho una query di inserimento che in Access mi funziona ma in SqlServer no. Ho dedotto che il problema sta nella data...ma non capisco...

Insert into Protocolli(IdSocieta,IdUfficio,IdPersona,TipoProto collo,IdMittenteDestinatario,Data,NumProtocollo,Og getto) Select 1,1,4,'U',1,#09/12/2002#,1,'Ciao Mondo!!!'

AIUTOOOOOOOOOOOOOOOOOOOOOOO

P.S. E' urgente...senza di questa non vado avanti!!!:dh:

Johnny_Depp
04-10-2002, 11:04
Domanda:

Per connetterti a Sql Server utilizzi la stessa
stringa di connessione che utilizzavi per connetterti ad Access?

forse il problema sta proprio li...

Mr.E
04-10-2002, 11:05
uso Odbc

Johnny_Depp
04-10-2002, 11:08
posta la stringa di connessione:

my_conn = ".................."

Johnny_Depp
04-10-2002, 11:14
Aspetta un momento:

INSERT INTO tabella (campo1,campo2) VALUES ('X','Y')

tu hai messo INSERT INTO (campo1,campo2) SELECT???????

Forse l'errore sta sulla query d'inserimento

Mr.E
04-10-2002, 11:45
le altre query le ho fatte tutte in quel modo comunque provo...

Mr.E
04-10-2002, 12:27
non funziona neanche in quel modo

Johnny_Depp
04-10-2002, 12:38
postami

il codice con il quale ti connetti.

Mr.E
04-10-2002, 12:44
Set WK_GP = CreateWorkspace("ODBCWork", "admin", "admin", dbUseODBC)

Set DB_SQL = WK_GP.OpenDatabase("Connection", dbDriverNoPrompt, False, "ODBC;DSN=" & FrmSetUp.TxtNomeDSN.Text & ";UID=" & FrmSetUp.TxtUtente.Text & ";PWD=" & FrmSetUp.TxtDbPassWord.Text & ";")

Comunque la cosa strana che le altre query mi funzionano tutte...ma non ci sono date...

Johnny_Depp
04-10-2002, 12:51
io utilizzo ADO!!!

cmq credo che il problema stia (come dicevi tu) sull'immissione del
campo data...

ora non ho Sql-Server installato sul mio PC altrimenti avrei provato
a risolvere il tuo problema...

prova ad inserire la data FORMATTATA in un'altro modo

ES:

gg/mm/aaaa oppure gg/mm/aa oppure aaaa/mm/gg oppure aa/mm/gg

forse SQL SERVER accetta le date in uno di questi modi.

Se risolvi fammi sapere quale era l'errore.

Loading