PDA

Visualizza la versione completa : configurazione di java


poca_hontas79
08-11-2002, 12:14
PROBLEMA...dopo aver installato tutto il kit jdk 1.4 non funzionava una mazza e ho cominciato a settare le variabili d'ambiente seguendo le istruzioni trovate qua e l in rete...ma continua a non funzionare! addirittura, ovunque trovo scritto ke nella cartellina lib di java ci deve essere un file chiamato classi.zip...ma io qst file non ce l'ho!!! come possibile?
:dh: ...sto sbattendo la testa un p ovunque, ho cominciato a fare i primi programmini, ma l'unico modo x farli funzionare (compilarli e interpretarli) salvarli nella cartellina bin di java.
qualcuno pu aiutarmi???
grazie
ciao

l.golinelli
08-11-2002, 12:22
Non hai settato bene la Path... Che S.O. hai??? :adhone:

userfra
08-11-2002, 12:25
nella variabile CLASSPATH, "settati" la directory dove vuoi che vengano eseguiti i tuoi file java, per esempio c:\classi!

ciao

l.golinelli
08-11-2002, 12:30
Cmq il fatto che non ti va javac.exe da qualsiasi cartella dipende dal PATH...


Win 2000 --> Variabili d'ambiente --> aggiungi la cartella bin nella stringa della PATH;

Win 9x --> Autoexec.bat --> aggiungi PATH=C:\cartella_che_contiene_javac.exe

Linux --> Mah...

:ciauz: :ciauz: :ciauz:

poca_hontas79
08-11-2002, 14:31
il path settato correttamente..di qst ne sono sicura! il mio problema di adesso ke ho dgt un programmino ke importa la classe java.until, ke una classe standard di java, ma quando tento di compilarlo mi d errore..mi dice ke qst classe non esiste...come possibile ke non esista una classe standard?
scusate..ma non sono molto pratica di java..magari non ho fatto qualcosa ke invece avrei dovuto fare...!
ciao e grazie

userfra
08-11-2002, 14:33
Originariamente inviato da poca_hontas79
il path settato correttamente..di qst ne sono sicura! il mio problema di adesso ke ho dgt un programmino ke importa la classe java.until, ke una classe standard di java, ma quando tento di compilarlo mi d errore..mi dice ke qst classe non esiste...come possibile ke non esista una classe standard?
scusate..ma non sono molto pratica di java..magari non ho fatto qualcosa ke invece avrei dovuto fare...!
ciao e grazie

devi settare una variabile JAVA_HOME = c:\sdk...

poi nel CLASSPATH devi aggiungere JAVA_HOME\bin

ciao

blinkago
08-11-2002, 18:06
Torno a proporre l'utilit della FAQ!

per la mia propota il thread questo (http://forum.html.it/forum/showthread.php?threadid=342871)



Cmq sei sicura!
guarde che la classe "java.util" non until

blinkago
08-11-2002, 18:08
java.util non una classe, un pakage e va importato cos:


import java.util.*;

blinkago
08-11-2002, 23:20
Faccio schifo!!!:quote:

package e non pakage!!!

proposta e non propota!!!


Smetter mai di fare errori di battitura?:dh: :dh:

Loading