PDA

Visualizza la versione completa : Tomcat


side-server
28-11-2002, 11:49
ciao a tutti, volevo installare tomcat5 (su win2000) per fare qualche prova con le jsp solo che dopo aver installato il jdk(j2sdkee1.3.1) e lo stesso tomcat5 + aver settato le relative variabili (JAVA_HOME e TOMCAT_HOME) d'ambiente mi compare un messaggio di errore nel lanciare il comando startup (vedi allegato). Pensando che fosse tomcat ho provato la versione 4 ma anche con quella al momento dello start mi da sempre lo stesso errore. :jam:
Mi sfugge qualcosa? :master:

grazie, ciao! :ciauz:

dany-
28-11-2002, 11:59
Bhe, devi settare la variabile Java_home come dice nel msg di errore. Hai installato il jdk? Che win usi??

Io la settimana scorsa ci sono stato sopra per 4 ore per farlo girare. Una sola parola: java. :dh: :dh:

Ciao
Daniele

dany-
28-11-2002, 12:01
dimenticavo, hai settato la variabile path sul percorso \bin del jdk?

side-server
28-11-2002, 12:27
non che per caso devo modificare qualche file ? le variabili d'ambiente che ho settato sono:

JAVA_HOME=D:\j2sdkee1.3.1
TOMCAT_HOME=D:\Tomcat5.0
JAVA_PATH=D:\j2sdkee1.3.1\bin

Nella cartella di tomcat (d:\Tomcat5.0) non ho modificato NESSUN file. come gia scritto sono su win2000, con j2sdkee1.3.1 e avevo gi settato le variabili e pure riavviato il pc.
Help me! :dh: :dh:

ciao :ciauz:

side-server
28-11-2002, 12:30
questo l'errore che mi da allo start:


D:\Tomcat5.0\bin>startup
The JAVA_HOME environment variable is not defined correctly
This environment variable is needed to run this program
Using CATALINA_BASE: ..
Using CATALINA_HOME: ..
Using CATALINA_TMPDIR: ..\temp
Using JAVA_HOME: D:\j2sdkee1.3.1
Impossibile trovare il file -Djava.endorsed.dirs=.

dany-
28-11-2002, 12:41
Io java_path non l'ho settato, devi invece settare il percorso che hai usato per java_path nella variabile "path", dovrebbero esserci gi delle definizioni. Non serve riavviare. Per vedere se funziona prova in un prompt di dos a far partire un programma che si trova nella cartella \bin del java, tipo "javac".

Daniele

pippo75
28-11-2002, 12:47
non vorrei dire baggianate, ma la J2EE un qualcosa in +, che si appoggia alla J2SE
quindi mi sa che invece di far puntare la JAVA_HOME alla dir dell'Enterprise Edition devi farla puntare a quella della standar edition

dany-
28-11-2002, 12:55
Bho, a me funziona con la versione base jdk 1.3...

Daniele

side-server
28-11-2002, 13:38
ok ci sono riuscito, effetivamente con la versione del jdk enterprise non gira, ho installato la standard (j2sdk1.4.1_01) e funziona perfetto adesso!

:mavieni: :mavieni:

grazie 1000 raga ! ciao! :ciauz: :ciauz:

Loading