PDA

Visualizza la versione completa : classpath


abcd1000
21-05-2003, 21:16
Ho come s.o. win Xp pro
lancio la shell command.com
sono in c:

se scrivo java e premo invio mi riconosce il comando
se scrivo javac e premo invio mi dice che non riconosce il comando

se vado in c:\sdk\bin e scrivo javac mi dice che riconosce il comando

Come faccio a fargli riconoscere il comando javac anche da c: ?

Ho già nella variabile di ambiente "path" del sistema il path
;c:\sdk\bin
ed ho riavviato il pc
ma non ha risolto il problema

userfra
22-05-2003, 09:59
Originariamente inviato da abcd1000
Ho come s.o. win Xp pro
lancio la shell command.com
sono in c:

se scrivo java e premo invio mi riconosce il comando
se scrivo javac e premo invio mi dice che non riconosce il comando

se vado in c:\sdk\bin e scrivo javac mi dice che riconosce il comando

Come faccio a fargli riconoscere il comando javac anche da c: ?

Ho già nella variabile di ambiente "path" del sistema il path
;c:\sdk\bin
ed ho riavviato il pc
ma non ha risolto il problema

:master:
molto strano, sei sicuro di aver inserito nella variabile PATH(già esistente in Win) il percorso sdk\bin?

Xadoom
22-05-2003, 10:28
anche io....setsso strano problema:
java lo riconosce,javac no!!:confused:

abcd1000
22-05-2003, 15:25
ti dirò di piu se dal path delle variaibili d'ambiente tolgo
c:\sdk\bin

il comando java scritto da c: lo continua a riconoscere (mentre javac no)

come fa il sistema a capire dove andare a ricercare il comando java se non ce lo ha scritto nel path?!?

abcd1000
22-05-2003, 15:26
questo è tutto quello che ho attualemnte scritto nella variabile d'ambiente path

%SYSTEMROOT%\system32;C:\PROGRA~1\PANDAS~1\PANDAA~ 1.0;%SYSTEMROOT%;%SYSTEMROOT%\COMMAND;%SYSTEMROOT% \system32\WBEM;C:\Programmi\Rational Rose\bin\win32;C:\Programmi\common;c:\programmi\ra tional rose\bin\win32;C:\Programmi\common;C:\j2sdk\bin

Zero-2
22-05-2003, 18:42
Hai installato JBuilder versione v.7??
Era lui il responsabile di questo problema sul mio pc.
Ho risolto eliminando il file java.exe presente in una sottodirectory di c:\windows.
Cmq per sicurezza fai una ricerca :)

CIauz
:ciauz:

abcd1000
22-05-2003, 21:38
non ho jbuilder installato e mai l'ho instalalto

però ho trovato un java.exe sotto windows/system32
l'ho tolto ed adesso il comando java da c non parte più

però non sono riuscito ancora a far partire il comando java e javac da c: anche se nella variabile d'ambiente path c'è specificato ;c:\j2sdk\bin

why?

Zero-2
23-05-2003, 18:45
Puoi postare il PATH??
Se è a posto deve funzionare .
Ciauz
:ciauz:

abcd1000
23-05-2003, 23:53
Il mio path è

%SYSTEMROOT%\system32;C:\PROGRA~1\PANDAS~1\PANDAA~ 1.0;%SYSTEMROOT%;%SYSTEMROOT%\COMMAND;%SYSTEMROOT% \system32\WBEM;C:\Programmi\Rational Rose\bin\win32;C:\Programmi\common;c:\programmi\ra tional rose\bin\win32;C:\Programmi\common;C:\j2sdk\bin

Zero-2
24-05-2003, 00:10
E' strano , lasciando stare le ripetizioni di alcuni Path , deve funzionare...
prova a disinstallare la jdk e a reinstallarla...:(

P.S. Scusa se ti ho fatto ripostare il PATH , ma solo ora mi sono accorto che lo avevi già postato :(:(

Loading