PDA

Visualizza la versione completa : [info] kernel 2.6.0 e driver nvidia


side-server
05-01-2004, 17:33
ciao a tutti, sfrugugliando per il web ho trovato questo (http://www.sh.nu/download/nvidia/linux-2.6/) link dove è possibile scaricare i driver NVIDIA per il kernel 2.6.0. I driver non sono ufficiali, sono la versione già patchata dei driver reperibili su minion.de (http://www.minion.de/) , per installare questi driver bisogna scaricare i pacchetto NVIDIA-Linux-x86-1.0-5328-pkg0.run , uscire da X, da root lanciare sh NVIDIA-Linux-x86-1.0-5328-pkg0.run e seguire i passaggi. una volta che i moduli sono stati compilati nel file XF86Config bisogna fare delle modifiche, eliminare, se sono presenti, le rige: Load "dri" e Load "GLcore" , dopodichè ne va aggiunta una, se non è già presente; Load "glx". Ultimo passaggio è quello di modificare il nome del driver video che la scheda dovrà utilizzare quindi alla riga Video Device modificare il nome del driver che avete con nvidia , vi riporto un'esempio della configurazione:

# ***********************
# Graphics device section
# ***********************

Section "Device"
Identifier "Video"
Driver "nvidia"
VideoRam 128000
EndSection

spero che questo 3d possa essere di aiuto a tutti quelli che sono alle prese con questo problema dei driver.

:ciauz:

osiryx
05-01-2004, 18:06
Piccola curiosità....elimini dal file Load "dri" e nel kernel modifiche nn ne devi fare ?

side-server
05-01-2004, 18:10
nel readme non dicono niente a riguardo quindi non credo.

:ciauz:

side-server
26-01-2004, 20:58
rilasciati il 22 gennaio i nuovi driver nvidia 5332

PunkIvi
26-01-2004, 22:08
E io che ho fatto un casino per farli girare su 2.6 :dhò: :dhò:

arcobalenos
26-01-2004, 22:09
Originariamente inviato da side-server
rilasciati il 22 gennaio i nuovi driver nvidia 5332
Quelli sono per amd64, comunque oggi sono usciti anche i 5336 per x86

lnessuno
26-01-2004, 22:19
Originariamente inviato da osiryx
Piccola curiosità....elimini dal file Load "dri" e nel kernel modifiche nn ne devi fare ?


rispondo io... nel kernel non è necessaria nessuna modifica: )

pdpmpd
26-01-2004, 23:12
:cry: :cry: :cry: Perché non mi funzionano i 53? :cry: :cry:
... la sfid(g)a continua ...

side-server
27-01-2004, 02:33
Originariamente inviato da pdpmpd
:cry: :cry: :cry: Perché non mi funzionano i 53? :cry: :cry:
... la sfid(g)a continua ...

:master:

qual'è il prob ? io li ho appena installati e direi che funzionano egregiamente

sh-2.05b$ glxgears
8725 frames in 5.0 seconds = 1745.000 FPS
10080 frames in 5.0 seconds = 2016.000 FPS
10079 frames in 5.0 seconds = 2015.800 FPS
10078 frames in 5.0 seconds = 2015.600 FPS
10078 frames in 5.0 seconds = 2015.600 FPS
10082 frames in 5.0 seconds = 2016.400 FPS
10078 frames in 5.0 seconds = 2015.600 FPS
10058 frames in 5.0 seconds = 2011.600 FPS

(GeForce4 MX 440 - 128DDR)

:sexpulp:

edit: per caso sapete dov'è l'immagine con il logo della nvidia che si vede all'avvio di X ?

PunkIvi
27-01-2004, 12:02
Anche a me e vanno benone

iviosl@debian:~$ glxgears
31442 frames in 5.0 seconds = 6288.400 FPS
33437 frames in 5.0 seconds = 6687.400 FPS
33696 frames in 5.0 seconds = 6739.200 FPS

:mavieni:

Loading