PDA

Visualizza la versione completa : errore visualizzazione applet java


giovi73
20-01-2004, 20:25
ho un problema di visualizzazione con un applet java.
l'errore visualizzato il seguente:

ava.lang.ClassNotFoundException: tw.com.dlink.products.di.gui.SystMgmtTerm.class

at sun.applet.AppletClassLoader.findClass(Unknown Source)
at sun.plugin.security.PluginClassLoader.findClass(Un known Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.applet.AppletClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.applet.AppletClassLoader.loadCode(Unknown Source)
at sun.applet.AppletPanel.createApplet(Unknown Source)
at sun.plugin.AppletViewer.createApplet(Unknown Source)
at sun.applet.AppletPanel.runLoader(Unknown Source)
at sun.applet.AppletPanel.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

Caused by: java.io.FileNotFoundException: C:\JavaClass\tw\com\dlink\products\di\tw\com\dlink \products\di\gui\SystMgmtTerm\class.class (Impossibile trovare il percorso specificato)
at java.io.FileInputStream.open(Native Method)
at java.io.FileInputStream.<init>(Unknown Source)
at java.io.FileInputStream.<init>(Unknown Source)
at sun.net.www.protocol.file.FileURLConnection.connec t(Unknown Source)
at sun.net.www.protocol.file.FileURLConnection.getInp utStream(Unknown Source)
at sun.applet.AppletClassLoader.getBytes(Unknown Source)
at sun.applet.AppletClassLoader.access$100(Unknown Source)
at sun.applet.AppletClassLoader$1.run(Unknown Source)
at java.security.AccessCo


sto impazzendo...: per favore, qualcuno riesce a dirmi cosa c' che non va e perch non riesco a visualizzare correttamente la pagina?

grazie 1000 :dh:

LeleFT
21-01-2004, 00:47
Non trova la classe SystMgmtTerm di questo package: tw.com.dlink.products.di.gui

Controlla che esista (sia il package che la classe).


Ciao.

giovi73
22-01-2004, 14:46
grazie per la tua risposta.
ho controllato nel mio pc e ho trovato la directory tw/com/dlink/products/di/gui e all'interno c' la classe SystMgmtTerm.class, quindi non ci dovrebbero essere problemi.
Invece non riesco lo stesso ad aprire la pagina...
Hai qualche idea su come posso fare?

Grazie 1000

LeleFT
22-01-2004, 19:33
Potrebbe essere un problema di classpath. Controlla se il classpath impostato correttamente.


Ciao.

LeleFT
22-01-2004, 19:40
Allora potrebbe essere un problema di classpath. Controlla che il classpath sia impostato correttamente.


Ciao.

giovi73
22-01-2004, 22:00
Scusami... mi puoi dire esattamente che cosa devo verificare? Non sono un'esperta di java, di class, ecc. ecc... :dh:

Grazie 1000 ancora

Loading