PDA

Visualizza la versione completa : Errore NAT su rete 2 pc


Kintaro
02-02-2004, 12:54
Premessa: ho 2 pc collegati in rete con cavo invertito, ho già letto tutte la faq in rilievo, la configurazione è la seguente:

SERVER:
win 2000
IP: 192.168.0.1
mask: 255.255.255.0
gateway: nulla
DNS preferito: 192.168.0.1
DNS secondario: nulla

CLIENT
win XP
IP: 192.168.0.2
mask: 255.255.255.0
gateway: 192.168.0.1
DNS preferito: 192.168.0.1
DNS secondario: nulla

sul primo pc ho un moden ISDN con una connessione impostata in "internet connection sharing".

Sia la rete che la condivisione del modem funzionano apparentemente bene.

Nei log eventi di win200 sul computer principale trovo un errore, ripetuto tantissime volte, ma proprio pieno:

Evento: 32003
Origine: IPNATHLP
Descrizione: NAT ( Network Address Translator) non è riuscito a richiedere un'operazione del modulo di traduzione in modalità kernel. Errata configurazione, risorse insufficienti o errore interno. Il codice di errore è nei dati.

ho trovato questo articolo di MS (http://support.microsoft.com/?kbid=293497) che parla esattamente di quell'errore e volendo cerca pure di spiegarne la risoluzione, ma onestamente non c'ho capito molto...

Help please, chi ne sa di più e mi traduce la suluzione proposta da MS?

grazie

dAbOTZ
02-02-2004, 13:20
Vai sotto Strumenti di amministrazione --> routing e accesso remoto o qualcosa di simile (vado a memoria), li` trovi le impostazioni per il nat. Dovresti modificare la subnet mask in base a quella che ti viene rilasciata sulla wan, dai un ipconfig /all dal server e guarda cosa ti viene rilasciato. Guarda qui (http://www.computing.net/howto/advanced/2000nat/NAT.pdf), la schermata dove configuri l'address pool e` a pagina 7

Kintaro
02-02-2004, 14:48
Documento molto interessante e interessanti anche gli articoli linkati in fondo, tuttavia mi pare di aver capito che il servizio "routing e accesso remoto" da t citato sia disponibile solo sotto win2000 server mentre io ho win2000 pro.. mi confermi?


Dovresti modificare la subnet mask in base a quella che ti viene rilasciata sulla wan, dai un ipconfig /all dal server e guarda cosa ti viene rilasciato.

ipcofig /all restituisce:

Configurazione IP di Windows 2000

Nome host . . . . . . . . . . . : pcfisso
Suffisso DNS primario . . . . . :
Tipo nodo . . . . . . . . . . . : Trasmissione
IP Routing abilitato. . . . . . : Sì
WINS Proxy abilitato. . . . . . : No

- Scheda Ethernet Connessione alla rete locale (LAN):

Suffisso DNS specifico connessione:
Descrizione . . . . . . . . . . : Scheda Fast Ethernet PCI Realtek RTL
Indirizzo fisico. . . . . . . . : 00-10-A7-1A-7
DHCP abilitato . . . . . . . . . : No
Indirizzo IP. . . . . . . . . . . : 192.168.0.1
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Gateway predefinito . . . . . . . :
Server DNS. . . . . . . . . . . : 192.168.0.1

- Scheda PPP Tag 10:

Suffisso DNS specifico connessione:
Descrizione . . . . . . . . . . : WAN (PPP/SLIP) Interface
Indirizzo fisico. . . . . . . . : 00-53-45-00-0
DHCP abilitato . . . . . . . . . : No
Indirizzo IP. . . . . . . . . . . : 62.94.66.*
Subnet Mask . . . . . . . . . . . : 255.255.255.255
Gateway predefinito . . . . . . . : 62.94.66.*
Server DNS. . . . . . . . . . . : 62.94.0.1
62.94.0.2
NetBIOS su Tcpip. . . . . . . . : Disabilitata


Quindi, fammi capire, devo mettere 255.255.255.255 anzichè 255.255.255.0 ?

dAbOTZ
02-02-2004, 14:56
Alt! Io davo per scontato che tu avessi win2k server.. sul pro non ti so aiutare per quell'errore.

seclimar
02-02-2004, 15:35
prova a togliere il DNS 192.168.0.1 dal SERVER e lascia in bianco...

controlla se esce ancora l'errore...

mogew
02-02-2004, 22:41
Anche a me capita quell'errore su Windows XP Pro, credo che sia dovuto al fatto che avendo attivato la Condivisione della connessione ad Internet, il Pc principale "cerca" l'altro Pc con cui condivide la connessione, ma in quel momento il secondo Pc è spento.

Ciao

seclimar
03-02-2004, 12:00
puo' essere...
specie se si usa un collegamento pc pc con cavo crossed...
(il pc spento fa si che la connessione di rete sia disattivata...)

verifica se l'errore appare solo quando il client e' spento...

Kintaro
04-02-2004, 23:57
si è vero, l'errore si presenta solo col pc secondario spento o in pausa... la cosa però è scocciante, l'80% dei log sono infestati da quell'avviso :nonlodire

seclimar
05-02-2004, 11:13
quanti log ??
(intendo la frequenza) espressa in errori al minuto..

Loading