PDA

Visualizza la versione completa : Cisco 1721, p2p e VNC


gatsby
11-02-2004, 09:54
Salve, sto realizzando la configurazione di un router adsl cisco 1721 ma sinceramente ho alcuni problemi con le connessioni dall'esterno.
Connettendomi con il vnc da remoto sulla porta 5800 non riscontro particolari problemi, ma quanod attivo amule oppure overnet, il router, dopo un periodo di tempo variabile, perde l'indirizzo ip assegnatogli dal server e si blocca, costringendomi a riaccenderlo.

Ho provato a modificare il time-out tcp ed udp, ma con scarsi risultati.
Stessa cosa con ip translation max-entries.

Sinceramente non so più dove mettere le mani!!

Ogni aiuto sarà prezioso!!

Grazie mille

dAbOTZ
11-02-2004, 10:25
Intanto prova a dare un show process cpu in condizioni di alto traffico e guarda la percentuale di lavoro della cpu, nelle stesse condizioni dai un bel show interfaces e riporta i valori di input e output queue.

gatsby
11-02-2004, 10:33
appena il router è in condizioni di stress posterò il risultato dei comandi da te indicati.

Per show interfaces serve solo la parte relativa all'atm o tutto l'output?

dAbOTZ
11-02-2004, 10:37
Sufficiente atm, ma gia` che ci siamo diamo anche un'occhiata al resto

gatsby
11-02-2004, 16:53
Il router si è appena piantato...
A questo link:
http://mio.discoremoto.virgilio.it/linguaggio/

ci sono i file dell'output dei comandi che mi hai indicato.
Non li posto qui perchè sono ovviamente molto lunghi.

Se quando hai tempo potessi dar loro uno sguardo te ne sarei immensamente grato.

Mi sono anche scordato di dire che amul occupa tutta la banda disponibile e non mi consente di navigare allo stesso tempo.

Di seguito posto la conf del router:

Using 1526 out of 29688 bytes
!
version 12.2
service config
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
no service dhcp
!
hostname paoletto
!
no logging buffered
enable secret 5 $1$6AI3$fS0RVzQGPvstZekPasu2J/
enable password ******
!
ip subnet-zero
no ip source-route
ip domain name tin.it
ip name-server 212.216.112.112
ip name-server 212.216.172.62
!
!
!
!
!
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 8/35
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
dsl operating-mode auto
hold-queue 224 in
!
interface FastEthernet0
ip address 192.168.1.1 255.255.255.0
ip nat inside
speed auto
full-duplex
no cdp enable
!
interface Dialer0
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
no cdp enable
ppp chap hostname confidenceman@tin.it
ppp chap password 0 *****
ppp pap sent-username confidenceman@tin.it password 0 *****
!
interface Dialer1
no ip address
!
ip nat translation tcp-timeout 6000
ip nat translation udp-timeout 500
ip nat translation max-entries 500
ip nat inside source list 1 interface Dialer0 overload
ip nat inside source static tcp 192.168.1.2 4662 interface Dialer0 4662
ip nat inside source static udp 192.168.1.2 4665 interface Dialer0 4665
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
no ip http server
!
!
no logging trap
access-list 1 permit 192.168.1.0 0.0.0.255
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
password ******
login
!
scheduler max-task-time 5000
no scheduler allocate
end

Grazie

dAbOTZ
11-02-2004, 17:28
La configurazione mi sembra a posto. Il carico della cpu e` irrisorio, a lume di naso direi che bisogna indagare su questo valore:



Input queue: 0/224/0/0 (size/max/drops/flushes); Total output drops: 1842


Sembra che ci siano dei problemi in upload. Dai ancora un show buffers e posta i risultati.

gatsby
11-02-2004, 23:58
Buffer elements:
459 in free list (500 max allowed)
262699 hits, 0 misses, 0 created

Public buffer pools:
Small buffers, 104 bytes (total 93, permanent 50, peak 93 @ 00:11:24):
50 in free list (20 min, 150 max allowed)
101065 hits, 26 misses, 0 trims, 43 created
0 failures (0 no memory)
Middle buffers, 600 bytes (total 25, permanent 25):
23 in free list (10 min, 150 max allowed)
4313 hits, 0 misses, 0 trims, 0 created
0 failures (0 no memory)
Big buffers, 1536 bytes (total 50, permanent 50):
47 in free list (5 min, 150 max allowed)
31608 hits, 0 misses, 0 trims, 0 created
0 failures (0 no memory)
VeryBig buffers, 4520 bytes (total 68, permanent 10, peak 68 @ 01:35:08):
68 in free list (0 min, 100 max allowed)
3078 hits, 29 misses, 0 trims, 58 created
0 failures (0 no memory)
Large buffers, 5024 bytes (total 0, permanent 0):
0 in free list (0 min, 10 max allowed)
0 hits, 0 misses, 0 trims, 0 created
0 failures (0 no memory)
Huge buffers, 18024 bytes (total 2, permanent 0, peak 2 @ 01:25:36):
2 in free list (0 min, 4 max allowed)
0 hits, 1 misses, 0 trims, 2 created
0 failures (0 no memory)

Header pools:
Header buffers, 0 bytes (total 137, permanent 128, peak 137 @ 01:35:14):
9 in free list (10 min, 512 max allowed)
125 hits, 3 misses, 0 trims, 9 created
0 failures (0 no memory)
128 max cache size, 128 in cache
19 hits in cache, 0 misses in cache

Particle Clones:
1024 clones, 0 hits, 0 misses

Public particle pools:
F/S buffers, 256 bytes (total 384, permanent 384):
128 in free list (128 min, 1024 max allowed)
256 hits, 0 misses, 0 trims, 0 created
0 failures (0 no memory)
256 max cache size, 256 in cache
0 hits in cache, 0 misses in cache
Normal buffers, 1548 bytes (total 512, permanent 512):
384 in free list (128 min, 1024 max allowed)
224 hits, 0 misses, 0 trims, 0 created
0 failures (0 no memory)
128 max cache size, 128 in cache
0 hits in cache, 0 misses in cache

Private particle pools:
FastEthernet0 buffers, 1536 bytes (total 192, permanent 192):
0 in free list (0 min, 192 max allowed)
192 hits, 0 fallbacks
192 max cache size, 128 in cache
111663 hits in cache, 0 misses in cache
Serial0 buffers, 1548 bytes (total 32, permanent 32):
0 in free list (0 min, 32 max allowed)
32 hits, 0 fallbacks
32 max cache size, 16 in cache
51832 hits in cache, 0 misses in cache
Serial0 buffers, 1548 bytes (total 32, permanent 32):
0 in free list (0 min, 32 max allowed)
32 hits, 0 fallbacks
32 max cache size, 16 in cache
59384 hits in cache, 0 misses in cache

pieba1
12-02-2004, 00:21
Non è che i 2 programmi di p2p aprono troppe connessioni ed impallano il router?

dAbOTZ
12-02-2004, 00:23
Public buffer pools:
Small buffers, 104 bytes (total 93, permanent 50, peak 93 @ 00:11:24):
50 in free list (20 min, 150 max allowed)
101065 hits, 26 misses, 0 trims, 43 created
0 failures (0 no memory)


Buffer leak, transitano piu` pacchetti di quanti riesca a gestire. Essendo un bug dell'ios l'unica soluzione e` aggiornarlo, che versione hai? show version


nb: non e` detto che l'aggiornamento risolva..

gatsby
12-02-2004, 09:27
Cisco Internetwork Operating System Software
IOS (tm) C1700 Software (C1700-Y7-M), Version 12.2(8)YL, EARLY DEPLOYMENT RELEAS E SOFTWARE (fc1)
Synched to technology version 12.2(10.3)T1
TAC Support: http://www.cisco.com/tac
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Wed 17-Jul-02 14:41 by ealyon
Image text-base: 0x80008124, data-base: 0x809B71C8

ROM: System Bootstrap, Version 12.0(3)T, RELEASE SOFTWARE (fc1)
ROM: C1700 Software (C1700-Y7-M), Version 12.2(8)YL, EARLY DEPLOYMENT RELEASE SO FTWARE (fc1)

paoletto uptime is 20 minutes
System returned to ROM by power-on
System image file is "flash:c1700-y7-mz.122-8.YL.bin"

cisco 1720 (MPC860T) processor (revision 0x601) with 44237K/4915K bytes of memor y.
Processor board ID VMS064400N4 (4265240773), with hardware revision 0000
MPC860T processor: part number 0, mask 32
Bridging software.
X.25 software, Version 3.0.0.
1 FastEthernet/IEEE 802.3 interface(s)
1 ATM network interface(s)
32K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102



La versione è la 12.2(8), in effetti ce ne sono di più aggiornate.
Avevo pensato anche io di aggiornarlo ma ho paura di fare danni,senza contare che non ho la più pallida idea di dove reperire l'aggiornamento!!
Infine, il suddetto aggiornamento cosa comporta a livello di settaggi?
Devo semplicemente ripristinare la configurazione oppure agire ad altri livelli?
Ho letto la documentazione Cisco che tuttavia, per via delle mie lacune in materia, non mi è stata molto esplicativa.


Grazie

Loading