PDA

Visualizza la versione completa : Problema con FTP


Dichy
19-03-2004, 01:18
Ho un PC ed un Portaile che sono collegati ad uno switch al quale stato collegato un Router (Zyxel 650-31), ho configurato il router affinch entrambi i PC possano navigare allo stesso tempo in quanto il ruter che si collega direttamente ad intenet.
Il problema questo, prima che mi arrivasse il potatile allo switch era collegato il solo PC e la connessione avveniva manualmente, avendo anche un FTP quando lo facevo partire il programma mi prendeva in automatico l'IP che mi veniva assegnato e non avevo alcun problema a collegarmici io oppure i miei amici.
In questa nuova configurazione invece quando faccio partire il programma di FTP (BulletProof FTP) all'FTP viene associato l'IP della scheda di rete e non quello dell'ISP, credo che questa cosa sia normale ma, c' un modo o un programma che mi permetta di associare nuovamente l'IP corretto? Faccio anche presente che utilizzo dyndns.org che associa al mio IP dinamico un IP "statico" ogni volta che mi scollego/collego ad internet.
Grazie.

internet
19-03-2004, 01:48
prova cos:
fai in modo che il server ftp faccia il bind sull'indirizzo 0.0.0.0

Dichy
19-03-2004, 08:52
Ti ringrazio x avermi risposto, ho controllato tutte le opzioni del programma x FTP (x sicurezza ne ho installato anche un altro) ma non ho trovato nessuna opzione che parlasse di "Blind"....:(

seclimar
19-03-2004, 09:40
non ho capito tanto il problema!

vediamo

tu hai un ftp server....
e non riesci a contattarlo dall'esterno !
e' cosi' ??


da dentro la rete funziona ?

Dichy
19-03-2004, 09:48
Originariamente inviato da seclimar
non ho capito tanto il problema!

vediamo

tu hai un ftp server....
e non riesci a contattarlo dall'esterno !
e' cosi' ??


da dentro la rete funziona ?

Esatto, il problema proprio questo, non riesco a contattarlo dall'esterno, se provo a collegarmi all'IP che mi viene fornito dall'ISP in pratica mi collego al router,se invece provo a dall'interno della LAN non ho nessun problema.

seclimar
19-03-2004, 10:04
Originariamente inviato da Dichy
Esatto, il problema proprio questo, non riesco a contattarlo dall'esterno, se provo a collegarmi all'IP che mi viene fornito dall'ISP in pratica mi collego al router,se invece provo a dall'interno della LAN non ho nessun problema.

hai configurato il NAT del router e reindirizzato la porta 21 dal router al ip privato dove c'e' il ftp server?

indre
19-03-2004, 10:14
ciao..

sullo zyxel 650R il vi gi un filtro per la porta 21 (in ingresso) se non ricordo male..
entra nel menu 21 dovrebbe essere il numero 12 o il numero 3.

guarda cosa fa.. se non erro anche qui.. dovrebbe essere ativo (Y).. e cancellare i pacchetti..
imposta active NO.
e poi fai il NAT come detto daseclimar nel menu 15.2.

controlla perch ho dormito poco e la mia memoria vacilla..
ciao :D

Dichy
19-03-2004, 10:21
Non ho mai impostato il NAT prima d'ora, ad ogni modo l'ho configurato come nel'immagine allegata...

indre
19-03-2004, 10:26
ciao..
no il menu il 15.2 SUA server e qualcosa..
dove hai start port end port e indirizzo ip locale...

la prima regola di NAT di defualt (dove vi scritto default) lasciala parti dalla numero due..
ciao

Dichy
19-03-2004, 10:42
Grazie x le risposte, ho capito dove devo impostare il NAT ma non ho capito come reindirizzare le porte

L'ho configurato cos:

Start Port No. End Port No. IP Address
1 All ports All ports 0.0.0.0
2 444 444 192.168.0.3


444 la porta che usvo in precedenza x il server FTP, ad ogni modo con questa configurazione ho lo stesso problema...

P.S: Nelle impostazioni sulla sicurezza ho disabilitato sia FTP che TFTP mentre ho lasciato abiliate Telnet, Web e SNMP.

Loading