PDA

Visualizza la versione completa : Quale proxy?


qmatteoq
01-04-2004, 00:27
Dovrei mettere su un proxy server in miniatura (devo installarlo sul pc fisso, al quale collego il mio portatile, visto che ho problemi nel usarlo come gateway). Quale mi consigliate? Ho provato AnalogX Proxy ma mi da tantissimi problemi, del tipo che digito un sito e mi carica l'home page di Google, oppure se clicco su un link tenta di aprirlo come riorsa di Google (ad esempio, se clicco su www.pippo.it/topolino/paperino.html, lui cerca di aprire www.google.it/topolino/paperino.html). Oppure spesso appaiono errori di File Not Found o "Errore nel proxy".

mfil
01-04-2004, 01:17
ma utilizzare squid per linux no è? :stordita:

qmatteoq
01-04-2004, 08:51
Peccato che io abbia bisogno proprio di Windows... Perchè se mio fratello sta giocando in Windows e io mi attacco con il portatile, come faccio a navigare?
Per Linux non mi serve neanche Squid comunque, visto che il problema che ho di condivisione della connessione si presenta solo in Windows...

seclimar
01-04-2004, 11:51
non puoi risolvere il problema della condivisione ??

per risolverlo continua qua
http://forum.html.it/forum/showthread.php?threadid=626712

e questa discussione non serve!
e' inutile aprire piu' discussioni

qmatteoq
01-04-2004, 13:07
Se il problema non è risolvibile, cosa devo farci scusa? Non postare più finchè non lo risolvo? Pure il mio prof. di reti quando gliel'ho detto non sapeva che fare... La domanda che ho posto in questo thread non c'entra niente con quello che avevo chiesto nell'altra... Che senso aveva continuarla? D'accordo non intasare il forum con thread inutili, ma mi sembra che qui si esageri un attimino...

dAbOTZ
01-04-2004, 13:17
Hai gia` provato WinProxy (http://www.winproxy.net/)?

qmatteoq
01-04-2004, 13:48
Si, l'ho provato ed è effettivamente meglio... Comunque ho risolto tutto... Mi hanno aiutato in un altro forum... E' un bug di Windows XP... Sui client bisogna settare un MTU inferiore a quello standard, altrimenti alcuni siti non vanno...
Te ne accorgi perchè se dai, ad esempio, ping -f -l 1499 192.168.0.1 (dove 1499 è la dimensione dell'MTU e 192.168.0.1 è l'indirizzo del gateway), invece di pingare normalmente ti dice che non riesce a frammentare il pacchetto.
Ora ho impostato l'MTU a 1450 e va alla perfezione...
Devo solo capire come modificare l'MTU in Linux, perchè lì si presenta ancora il problema...Ho già postato comunque nel forum apposito...

dAbOTZ
01-04-2004, 14:58
Ops :stordita:

'sta cosa dell'mtu me la devo appuntare da qualche parte, non me la ricordo mai :p

seclimar
01-04-2004, 16:50
Originariamente inviato da qmatteoq
Se il problema non è risolvibile, cosa devo farci scusa? Non postare più finchè non lo risolvo? Pure il mio prof. di reti quando gliel'ho detto non sapeva che fare... La domanda che ho posto in questo thread non c'entra niente con quello che avevo chiesto nell'altra... Che senso aveva continuarla? D'accordo non intasare il forum con thread inutili, ma mi sembra che qui si esageri un attimino...


IL PROBLEMA e' RISOLVIBILE !!!!!!!!!!!

dAbOTZ
01-04-2004, 16:52
Non urlare

Loading