PDA

Visualizza la versione completa : Cisco 827-Ricevere IP esterni


Rabinhood
01-04-2004, 14:05
Ho un router cisco 827 con 4 ip pubblici per alcuni pc ed altri ip privati. Tutto funziona perfettamente (sia quelli pubblici che quelli privati) ma da fuori non si riesce a visualizzare ne il server web ne entrare su un server vnc presente su un pc pubblico. Vorrei sapere qual'e' il comando per il ruoter cisco 827 che permette l'ingresso da pc esterni. (quelli della rete locale vedono sia il server web che vnc)

dAbOTZ
01-04-2004, 14:45
Puoi farlo facilmente dal websetup (http://indirizzo_lan_router da un browser qualsiasi), guarda qui (http://www.azacamis.com/cisco/827/napt.htm).

Rabinhood
01-04-2004, 17:32
Siccome non e' solo una questione di server web ma anche per esempio di un server vnc, non c'e' un comando da dare in console per permettere l'accesso a tutti gli ip senza restrizioni?

dAbOTZ
01-04-2004, 17:46
Ma il websetup e` una caratteristica dell'827, non una configurazione specifica per i webserver. Nel caso di vnc devi semplicemente seguire i passi descritti in quel link e abilitare la porta 5900.

Rabinhood
01-04-2004, 18:21
Non ho usato la funzione web perche' ci mette una vita a caricare la finestra della configurazione del router.....riprovero' questa sera con calma. Per adesso mille grazie.

dAbOTZ
01-04-2004, 18:24
Cito dal link:



for 1483, give this command

router(config)#ip nat inside source static tcp <INT PC IP> 80 <WAN IP> 80 extendable

for PPP, give this command

router(config)#ip nat inside source static tcp <INT PC IP> 80 interface dialer 0 80


sostituisci 80 alla porta del servizio

Rabinhood
03-04-2004, 13:45
Nulla da fare, non sono proprio esperto di router cisco, riesco giusto a impostarlo partendo da una configurazione prefatta. Vi copio quella che il mio provider ha fatto per il router cisco 827. Qualcuno puo' eventualmente "pulirla" o aggiungere qualcosa per permettere l'ingresso da fuori? Ho verificato per il vnc sulla porta 5900 (la porta e' giusta) ma nulla, da fuori non si entra). Ne sarei molto grato.

version 12.1
service timestamps debug datetime msec
service timestamps datetime msec
!
hostname F5-Router
!
username user password 0 password
!
enable password password
!
ip subnet-zero
ip domain name ngi.it.
ip name-server 213.92.5.54
ip name-server 194.185.88.5
!
ip dhcp excluded-address 10.0.0.1
!
ip dhcp pool LOCAL
network 10.0.0.0 255.0.0.0
default-router 10.0.0.1
dns-server 213.92.5.54 194.185.88.5
!
interface Ethernet0
ip address 188.188.188.188 255.255.255.248 sedondary
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
no ip mroute-cache
ip nat inside
no shutdown
!
interface ATM0
no ip address
no shutdown
no ip directed-broadcast
no ip mroute-cache
no atm ilmi-keepalive
pvc 8/35
encapsulation aal5snap
protocol ppp dialer
dialer pool-member 1
!
hold-queue 224 in
!
interface Dialer0
ip address negotiated
no ip directed-broadcast
encapsulation ppp
ip nat outside
dialer pool 1
dialer-group 1
ppp pap sent-username username password password
!
ip nat inside source list 101 interface Dialer0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
no ip http server
!
access-list 101 permit ip 10.0.0.0 0.255.255.255 any
dialer-list 1 protocol ip permit
!
line vty 0 4
login local


Questa e' la configurazione che il mio provider mette on-line, ma con questi valori non si entra nei pc che hanno ip fisso.

dAbOTZ
03-04-2004, 14:09
version 12.1
service timestamps debug datetime msec
service timestamps datetime msec
!
hostname F5-Router
!
username user password 0 password
!
enable password password
!
ip subnet-zero
ip domain name ngi.it.
ip name-server 213.92.5.54
ip name-server 194.185.88.5
!
ip dhcp excluded-address 10.0.0.1
!
ip dhcp pool LOCAL
network 10.0.0.0 255.0.0.0
default-router 10.0.0.1
dns-server 213.92.5.54 194.185.88.5
!
interface Ethernet0
ip address 188.188.188.188 255.255.255.248 sedondary
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
no ip mroute-cache
ip nat inside
no shutdown
!
interface ATM0
no ip address
no shutdown
no ip directed-broadcast
no ip mroute-cache
no atm ilmi-keepalive
pvc 8/35
encapsulation aal5snap
protocol ppp dialer
dialer pool-member 1
!
hold-queue 224 in
!
interface Dialer0
ip address negotiated
no ip directed-broadcast
encapsulation ppp
ip nat outside
dialer pool 1
dialer-group 1
ppp pap sent-username username password password
!
ip nat inside source list 101 interface Dialer0 overload
ip nat inside source static tcp 10.0.0.100 5900 interface Dialer0 5900
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
no ip http server
!
access-list 101 permit ip 10.0.0.0 0.255.255.255 any
dialer-list 1 protocol ip permit
!
line vty 0 4
login local


sostituisci 10.0.0.100 con l'indirizzo della macchina che ospita il server vnc

Rabinhood
05-04-2004, 10:53
Aggiorno la situazione....
Ho inserito la tua configurazione nel router cancellando quella vecchia modificando la riga postata con:
"ip nat inside source static tcp 188.188.188.189 5900 interface Dialer0 5900"
La macchina 188.188.188.189 (che ospita vnc, windows 2000) non permette l'ingresso di un client vnc.
Il router che ha ip 188.188.188.188 non viene pingato da fuori.
I pc della rete navigano senza problemi.
Un server debian 188.188.188.190 che ha aperto una porta di un programma in perl legge i dati che arrivano da un pc esterno che non fa parte della rete locale ma non e' visibile un server apache sulla medesima macchina.
Idee?

dAbOTZ
05-04-2004, 11:18
Sembra che non gli piaccia aprirla sul dialer.. prova con

ip nat inside source static tcp 188.188.188.189 5900 indirizzo_wan_router 5900 extendable

per l'altra macchina:

ip nat inside source static tcp 188.188.188.190 80 indirizzo_wan_router 80 extendable

c'e` un firewall in quella rete?

Loading