PDA

Visualizza la versione completa : Ati 9600 dri e mandrake10


ATHRAF
05-04-2004, 14:56
Salve, ho installato la mdk10 e devo dire che va benino... :gren: tutti i componenti sono riconosciuti al momento dell'inst. compreso la sk video, un ati 9600pro ma non mi
fa abilitare il supporto x il direct rendering indi niente
accelerazione 3d.
Ho provato anche a installare i driver ufficiali ati ma nulla, ho notato solo che le prestazioni in 2d sono aumentate.
Eseguendo glxinfo mi da:

name of display: :0.0
display: :0 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_ATI_pixel_format_float,
GLX_ATI_render_texture
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.3 Mesa 4.0.4
OpenGL extensions:
GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
GL_EXT_texture_lod_bias
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x23 24 tc 1 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 1 0 None
0x24 24 tc 1 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 1 0 None
0x25 24 tc 1 24 0 r y . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
0x26 24 tc 1 24 0 r . . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
0x27 24 dc 1 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 1 0 None
0x28 24 dc 1 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 1 0 None
0x29 24 dc 1 24 0 r y . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
0x2a 24 dc 1 24 0 r . . 8 8 8 8 0 16 8 16 16 16 16 1 0 None

Si vede chiaramente che il direct rendering non attivato ma le voci nell'Xconfig sono esatte, il caricamento dei moduli dri e glx c' allora dov'e' l'errore??? :master:

aspetto un'aiuto grazie :stordita:

:ciauz:

ATHRAF
05-04-2004, 18:04
:bh: help

c' nessuno che mi metta sulla buona strada???

:cry:


:ciauz: :ciauz:

eolusinternet
06-04-2004, 23:36
strano dovrebbe andare. A me andata al primo colpo.
Andiamo per passi:
installare il kernel-source
installare il driver forzando
fglrxconfig
cd /lib/modules/fglrx/build_mod
make.sh
cd /lib/modules/fglrx
make_install.sh
riavviare il pc
lsmod
dovresti avere fglrx, agp-gart e se hai un cheapset via via-agp
Ciao e fammi sapere

ATHRAF
06-04-2004, 23:46
ciao eolusinternet

usi la stessa mia distribuzione e la stessa skeda video e
a te ha configurato tutto in automatico???
cmq ho preso i driver dal sito ati x xfree4.3 e installati forzandoli
ovviamente ma nulla...
adesso nn sono in linux x controllare
ci vado subito e ti faccio sapere...

;) :ciauz:

ATHRAF
06-04-2004, 23:59
Allora ho dato lsmod e l'output questo:

Module Size Used by Not tainted
sg 34588 0 (autoclean) (unused)
st 30840 0 (autoclean) (unused)
sr_mod 18936 0 (autoclean) (unused)
sd_mod 13324 0 (autoclean) (unused)
scsi_mod 107360 4 (autoclean) [sg st sr_mod sd_mod]
lp 7712 0 (autoclean)
audigy 70380 1
ac97_codec 15540 0 [audigy]
sound 70280 0 [audigy]
soundcore 6244 0 [audigy sound]
nfsd 74128 8 (autoclean)
af_packet 14312 1 (autoclean)
ide-floppy 15776 0 (autoclean)
ide-tape 48240 0 (autoclean)
ide-cd 33092 0 (autoclean)
cdrom 34048 0 (autoclean) [sr_mod ide-cd]
floppy 55644 0
usbmouse 2744 0 (unused)
keybdev 2596 0 (unused)
mousedev 5140 1
hid 23940 0 (unused)
input 5696 0 [usbmouse keybdev mousedev hid]
8139too 16232 1 (autoclean)
mii 3816 0 (autoclean) [8139too]
ohci1394 27536 0 (unused)
ieee1394 202180 0 [ohci1394]
ntfs 76556 1 (autoclean)
nls_iso8859-15 4060 3 (autoclean)
nls_cp850 4284 2 (autoclean)
vfat 11948 2 (autoclean)
fat 38424 0 (autoclean) [vfat]
supermount 81888 2 (autoclean)
parport_pc 25544 1 (autoclean)
parport 34568 1 [lp parport_pc]
printer 8896 0 (unused)
ehci-hcd 19948 0 (unused)
usb-uhci 24976 0 (unused)
usbcore 75148 1 [usbmouse hid printer ehci-hcd usb-uhci]
rtc 8652 0 (autoclean)
ext3 60400 3
jbd 39552 3 [ext3]

cmq nn vedo ne fglrx ne agpgart (ah ho un chipset via px400 se nn erro su p4) devo necessariamente ricompilare il kernel
oppure solo alcuni moduli?? ma poi i sorgenti del kernel dove li scarico?? (nella compilazione sono inesperto)
Grazie dell'aiuto e se puoi dammi un consiglio...

:stordita:

ATHRAF
07-04-2004, 10:40
up

attendo risposte...

:sonno:

ATHRAF
07-04-2004, 18:31
:( upp

c'e' qualkunoo???

:ciauz:

eolusinternet
07-04-2004, 19:46
rieccomi.
ho visto il tuo output infatti manca il modulo fglrx e il modulo agp.
Isorgenti li trovi sul cd 3 kernel-source 2.6.3.ecc. se ricordo: comunque da root dai uname -a vedi che kernel hai installato poi dal cd installi l'omonimo source. Poi segui la procedura del mio post precedente.

ATHRAF
08-04-2004, 10:52
ho installato l'rpm del sorgente 2.6 presente nel 3cd di mdk10 comunity!
un casino cmq xch usa il kernel 2.4 ma
linux sembra puntare alla versione 2.6, inoltre alcuni
comandi x la compilazione o precedenti a essa manco li esegue
:bh: poi altro fatto da prendere nota che i driver ati non riescono a installare il loro pannello di controllo.
:confused: Ma forse la comunity manca di qualkosa xch anche
se a me funziona alquanto bene sembra mancare in parecchie cose,
tipo perch nel mio caso non installa dall'inizio certe cose che nn permettono l'avvio di prg come ad esempio wine/x.
Corregetemi se sbaglio ciao :confused:

:ciauz: :ciauz:

ATHRAF
08-04-2004, 11:06
:adhone: a tal proposito vorrei chiedere solo a chi l'ha installata
se la suse 9.0 riconosce in modo automatico in fase d'installazione
il direct rendering delle ati....

Loading