PDA

Visualizza la versione completa : [NVIDIA TNT2] Problemi X


mambro
06-04-2004, 19:32
Ultimamente nn riesco ad avviare 2 sessioni di X contemporaneamente, prima ci riuscivo...
Avvio la seconda sessione di X con startx : --2 e mi da



(EE) NVIDIA(0): Failed to allocate external video decoder object
(EE) NVIDIA(0): *** Aborting ***

Fatal server error:
AddScreen/ScreenInit failed for driver 0



che successo?

alex86
06-04-2004, 19:36
hai provato a reinstallare i driver?

mambro
06-04-2004, 20:02
Originariamente inviato da alex86
hai provato a reinstallare i driver?
Si, ho provato anche a cambiare versione dei drivers..

alex86
07-04-2004, 14:35
forse hai modificato male l'X86Config...

mambro
15-04-2004, 20:35
Originariamente inviato da alex86
forse hai modificato male l'X86Config...
Boo.. nn mi pare sbagliato..
Section "ServerLayout"

InputDevice "Mouse0" "CorePointer"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
EndSection

Section "Module"
Load "freetype"
Load "xtt"
#Load "opengl"
Load "glx"
#Load "dri"
#Load "dbe"
#Load "extmod"

#Load "record"
#Load "xtrap"
Load "type1"
Load "speedo"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbModel" "pc102"
Option "XkbLayout" "it"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Monitor0"
HorizSync 31.5 - 57.0
VertRefresh 50.0 - 90.0
EndSection

Section "Device"
Identifier "Nvidia Riva TNT2 m64 pro"
Driver "nvidia"
#ChipSet "nvidia RIVA TNT2 Model 64"
#Option "NvAGP" "3"
Option "RenderAccel" "true"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Nvidia Riva TNT2 m64 pro"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600"
EndSubSection
EndSection

alex86
15-04-2004, 20:48
mi sembra tutto ok!ke distro hai?ke versione dei driver hai installato? hai installato il kernel source?e il kernel header?

mambro
16-04-2004, 13:26
Sono riuscito a farlo andare... bastato togliere
Option "RenderAccel" "true"

ora funzia :mavieni:

Loading