PDA

Visualizza la versione completa : Direct Rendering? No!


TicC
10-04-2004, 21:07
ho seguito tutto ci che viene detto qui:
http://forum.html.it/forum/showthread.php?s=&threadid=427653&highlight=ATI
ma se metto in Section "Device"
Identifier "ATI Radeon 7000"
mi d degli errori in XF86Config all'avvio di X come posso risolvere?

fra7576
10-04-2004, 21:27
posta l'errore..

TicC
10-04-2004, 21:32
Using authority file /root/.Xauthority
Writing authority file /root/.Xauthority
Using authority file /root/.Xauthority
Writing authority file /root/.Xauthority


XFree86 Version 4.3.0
Release Date: 27 February 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.4.20 i686 [ELF]
Build Date: 01 March 2003
Before reporting problems, check http://www.XFree86.Org/
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Sat Apr 10 21:29:50 2004
(==) Using config file: "/etc/X11/XF86Config"
Data incomplete in file /etc/X11/XF86Config
Undefined Device "VESA Framebuffer" referenced by Screen "Screen 1".
(EE) Problem parsing the config file
(EE) Error from xf86HandleConfigFile()

Fatal server error:
no screens found

When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to xfree86@xfree86.org.

XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
after 0 requests (0 known processed) with 0 events remaining.

fra7576
10-04-2004, 21:41
l'identifier che cambi nella sezione device deve essere cambiato e messo uguale anche nella sezione screen.. controlla che sia cos



cmq cambiare l'identifier nn essenziale per avere l'acc. 3d.. l'importante mettere come driver "radeon", decommentare
load dri e mettere in section DRI mode 0666

TicC
10-04-2004, 21:44
si ho messo tutto il resto...
se metto
Identifier "VESA Framebuffer" mi risulta sempre facendo
glxinfo | grep rendering

direct rendering: No

:(

fra7576
10-04-2004, 21:47
hai riavviato x ? :fagiano:

TicC
10-04-2004, 21:47
adesso non mi d + l'errore in XF86Config ...ma il direct rendering rimane sempre su NO :dh: :dh: :dh:

TicC
10-04-2004, 21:48
certo che ho riavviato X

fra7576
10-04-2004, 21:54
il modulo radeon caricato ??

modprobe radeon

TicC
10-04-2004, 21:57
certo

Loading