PDA

Visualizza la versione completa : strano problema con debian


protoneee
12-04-2004, 20:01
Sono da poco passato al kernel 2.6, prima viaggiavo con il 2.4 ed andava tutto bene. Oggi cercando di installare l'ericsson hm120dp ho scoperto che non esiste il file /proc/pci
Avviando il sistema con il kernel 2.4 il file proc/pci mi riconpare e di conseguenza il modem funziona bene.
Sono sicuro che il problema nasce dalla compilazione del kernel 2.6 ma non so proprio come risolverlo.
grazie

andy caps
12-04-2004, 20:33
hai messo

/proc file system support
dal menu file system > pseudo ....


:bh: altrimenti controllerei il usbfs dalle usb se c'
e magari anche agiunggendo all'fstab una riga per montarlo cosi'

none /proc/bus/usb usbfs default 0 0

poi guarderei nella sezione general setup di avere messo

Support for paging of anonymous memory (swap) │ │
│ │ System V IPC │ │
│ │ BSD Process Accounting │ │
│ │ Sysctl support │ │
│ │ Support for hot-pluggable devices │ │
│ │ Kernel .config support

poi prova a mettere sempre da qui
Enable access to .config through /proc/config.gz

protoneee
12-04-2004, 22:29
/proc file system support
dal menu file system > pseudo ....

Si c'



Support for paging of anonymous memory (swap) │ │
│ │ System V IPC │ │
│ │ BSD Process Accounting │ │
│ │ Sysctl support │ │
│ │ Support for hot-pluggable devices │ │
│ │ Kernel .config support

poi prova a mettere sempre da qui
Enable access to .config through /proc/config.gz│

Kernel .config support non c'era
poi ho fatto quella modifica a fstab
Ho ricompilato il kernel di nuovo!

Ma nessuna novit, non funziona.

andy caps
12-04-2004, 22:50
prova a a dare un mount -a

o prova a mettere il dupporto per il devfs sempre nel gruppo fileystem anche se con debian in genere crea problemi a molti e dovresti installare udev e configurarlo

hexen
12-04-2004, 23:42
Ma il modem che funziona con gli eciadsl?
Se s mi pare che con il 2.6 si debba usare la versione CVS (che palle :/ )

:ciauz:

protoneee
13-05-2004, 00:03
Sono riuscito a far funzionare il modem, avevo la versione 0.8 che con il kernel 2.6 non funziona.
Scaricato la eciadsl0.9, patchato il kernel 2.6.5 ed ora funziona tutto alla meraviglia.

Grazie per gli aiuti comunque!

Loading