PDA

Visualizza la versione completa : debian: domande


Max256
13-04-2004, 05:52
ciao a tutti
questa sera mi son cimentato nella mia prima installazione di debian
dopo aver letto alcuni topic su questo e altri forum, ho preferito scaricare la debian da questo link http://ftp.bononia.it/debian-cd/3.0_r2/i386/ preso da uno dei tanti topic che hanno debian come tema centrale

l'installazione è andata a buon fine
ho caricato i moduli della scheda di rete e con pppoeconf ho settato la connessione e funge a meraviglia
ho caricato altri moduli (sto facendo girare debian su un Acer aspire 1315LM) e una volta loggato da root ho proceduto con l'installazione di xfree e kde con i comandi:
apt-get install x-window-system-core.
apt-get install kdebase kde-i18n-

premessa, non avevo ancora settato la connessione quindi ho installato il tutto utilizzando come fonte il cd1 NON US

fatto questo ho configurato xfree
il mio portatile possiede una S3 Graphics Savage8™ AGP a 32mb DDR
nella lista delle scheda ho provato sia selezionando Savage che S3virge che Vesa dall'elenco
Inoltre mi chiede un bus della scheda video del quale ignoro il valore
Anche la conf del monito tft non è propio semplice...almeno i valori da settare ho lasciato quelli di default, non sapendo in tutta onestà e fagianità :fagiano: cosa inserire
fatto ciò ho dato startx ma il sistema grafico non mi viene caricato

nella parte finale del log mi dice:
(--) Assignin device section with no busID to primary device
(EE) No device detected

Fatal server error:
no screens found

XIO: fatl IO error 104 (connection reset by peer) on X server ":0.0" after 0 request (0 known processed) with 0 events remaining

come posso procedere??

altra cosa che vorrei chiedervi, visto il mio primo approcci oa debian, esistono dei repository fondamentali da inserire per ottenere qualsiasi tipo di pacchetto e d iaggiornamento, o uno vale l'altro?? avreste buoni link da suggerirmi??


altra cosa, sul mio portatile (sperando di risolvere presto il problema del server grafico) aggiornerò moltissimi pacchetti all'ultima versione, ma intendo installare debian anche su un vecchio computer per riportarlo alla luce e mi chiedevo, con la woody, che versioni di kde o di gnome vengono installate??

un saluto a tutti, attendo con ansia vostre dritte :)

sirdrakes
13-04-2004, 10:30
Spero di avere capito il tuo problema....
Allora fai un lspci per vedere i parametri della tua scheda video, poi con modconf guarda se sono stati caricati i moduli per la scheda video in questione....se non sono stati caricati caricali :ciauz:

Max256
13-04-2004, 15:43
con lspci mi da:
host bridge: Via tecnologies, inc : unknown device 3156
pci bridge: via tecnologies, inc, VT8633 [Apollo Pro266 AGP]
cardbus bridge: 02Micro, inc: unknown device 6972
firewire (IEEE 1394) texas instruments: unknown device 8026
usb controller: via tecnlogies, inc, UHCI USB (rev80)
usb controller: via tecnlogies, inc, UHCI USB (rev80)
usb controller: via tecnlogies, inc, unknown device 3104 (rev82)
isa bridge: via tecnologies.inc: unknown device 3177
ide interface: via tecnologies, inc . Bus master IDE (rev06)
multimedia audio controller: via tecnologies,inc, AC97 audio controller (rev50)
Communication controller: Via tecnologies, inc. AC97 modem controller (rev80)
ethernet controller:via tecnologies, inc, Ethernet controller (rev74)
Vga compatible controller:S3 inc:unknown device 8d04


è possibile che la debian non supporti la mia scheda video??

andy caps
13-04-2004, 15:54
fai dpkg-reconfigure xserver-xfree86 e prova a mettere vesa come driver o trident o savage

la s3 non ricordo con esattezza che diver usi se cerchi con www.google.com/linux non ti dovrebbe essere difficile scoprirlo

virusbye
13-04-2004, 15:55
avvia knoppix da cd e copia l'XF86Config-4 di Knoppix in Debian... io ho risolto cosi'.

andy caps
13-04-2004, 15:58
per aggiornare tutto naturalmente basta mettere
queste due righe nel file /etc/apt/sources.list e ti trovi le ultime versioni di tutti i programmi
dopo avere dato un
apt-get update && apt-get dist-upgrade
deb ftp://debian.nettuno.it/debian/ unstable main contrib
deb-src ftp://debian.nettuno.it/debian/ unstable main contrib

Max256
13-04-2004, 16:05
ok provo subito..se non erro avevo letto un articolo dove linkavano ultimi driver da scaricare per la mia scheda video
thx virus e andy per le dritte
provo e vi faccio sapere ;)

Max256
14-04-2004, 16:53
riekkime a tempestarvi di domande
allora
dopo aver fatto un bel apt-get update e apt-get dist-upgrade
ho scaricato wget e installato i driver per la mia scheda video

ho riconfigurato X e per un attimo sembrava si stesse avviando, ma poi mi ha dato nuovi errori

vi riporto la parte finale

----------------------------------------------------------------------
savage backing store disabled
savage dpms enabled
savage: option "useFBdev" is not used
Keybord "generic Keyboard" handled by legacy driver
configured mouse: protocol: "Imps/2"
configured mouse: core pointer
configured mouse buttons: 3
configuredmouse emulate 3buttons,emulate3timeouts: 50
configured mouseù: ZaxisMapping: button 4 and 5
generic mouse: protocol: "imps/2"
generic mouse: always reports core events
xf860Openserial: cannot open device /dev/input/mice
no such device
Generic mouse:cannot open input device
Preinit failed for input device "generic mouse"
XINPUT:adding extended input device "configured mouse" (type:mouse)
cold not init font path element unix/:7100,removing from list!

waiting for X server to shut down
----------------------------------------------------------------------

che ho combinato con il mouse :stordita:
io possiedo un mouse usb (utilizzando il notebook), ma nn ho capito come configurarlo

vi sparo un'altra domanda, se voglio installare kde o gnome aggiornati o entrambi, li installo con il solito apt-get install nomeprog e magari con un gdm o kdm scelgo quale avviare esatto?

vi chiedo un'altra cosa, intendo aggiornare il kernel della debian portandolo a 2.6.4 o 2.6.5 quale mi consigliate? dove provo i pacchetti adatti al mio proc amd athlon2500+??

ringrazio anticipatamente tutti :)

gianiaz
14-04-2004, 17:02
Originariamente inviato da Max256

che ho combinato con il mouse :stordita:
io possiedo un mouse usb (utilizzando il notebook), ma nn ho capito come configurarlo


nel kernel hai abilitato le voci usb riguardanti HID ?


USB Human Interface Devices (HID)
<*> USB Human Interface Device (full HID) support

Max256
14-04-2004, 17:06
Oops, m'era sfuggito :dhò:

provo subito a riconfigurare :)

Loading