PDA

Visualizza la versione completa : named e resolv.conf


best1980
14-04-2004, 14:42
Ho da poco attivato Alice e navigo attraverso il mio server Debian woody. Su questa Debian è attivo il demone named(bind). Il problema è che ogni volta che faccio il boot del server e quindi viene attivata anche la connessione ADSL nel file resolv.conf mi trovo dentro i DNS di Alice che io però non voglio perchè nel file resolv.conf ci deve essere solo la linea: 'nameserver 127.0.0.1'. Come faccio a disabilitare questa cosa e fare in modo che non vengano scritti nel file resolv.conf i DNS di Alice???

GRAZIE

best1980
14-04-2004, 15:33
up ^

gianiaz
14-04-2004, 15:37
Originariamente inviato da best1980
up ^

la sparo proprio quindi non lapidatemi :p

potrebbe essere che nel resolv.conf hai questo:


search tin.it

best1980
14-04-2004, 15:58
no. io nel resolv.conf ho

nameserver 127.0.0.1


ma qunado mi connetto il resolv.conf diventa:

nameserver x.x.x.x

nameserver x.x.x.x

perchè? come disabilito l'aggiornamento del resolv.conf?

best1980
14-04-2004, 16:16
up ^

best1980
14-04-2004, 17:43
help me :dhò:

gigyz
14-04-2004, 17:59
ma ti colleghi con un modem ? non è un router vero ? prova a togliere l'opzione usepeerdns da /etc/ppp/options

best1980
15-04-2004, 09:41
Uso un modem ADSL (ericcson della telecom) e nel file options non ho quella direttiva...

HELP ME!!!

gigyz
15-04-2004, 10:35
ma che usi per connetterti (come soft intendo)? magari non usa gli script ppp quindi avrà qualche file di configurazione a parte dove disabilitare l'impostazione automatica dei dns, cmq io purtroppo non ho avuto mai il piacere di smanettare con adsl, ma questo fatto del bind .... non mi pare che sia così indispensabile per un ADSL il DNS caching, io lo uso ma ho GPRS, oppure ti serve per fare cose + serie ?

best1980
15-04-2004, 12:04
Io ho una rete locale composta da alcuni computer e quindi mi sono voluto configurare il mio server DNS. Per usarlo devo quindi inserire la direttiva 'nameserver 127.0.0.1' nelfile resolv.conf... ma resolv.conf durante la connessione con pppoe mi viene sovrascritto... come fare???

Loading