PDA

Visualizza la versione completa : Sistemare tabella routing


Meridian
15-04-2004, 08:59
Non so per quale motivo ma mi ritrovo una tabella di routing alcuanto sputtanata.

In pratica sono connesso in lan e via TA isdn contemporaneamente ma non pingo ne gli host sulla lan ne quelli su internet.

Ecco:

root@PISTONE:/etc# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
10.62.12.0 * 255.255.255.0 U 0 0 0 eth0
loopback * 255.0.0.0 U 0 0 0 lo
62.0.0.0 * 255.0.0.0 U 0 0 0 ippp0

A me non pare normale che non vi siano i gateway?
Come posso sistemare la cosa?
Grazie.

gianiaz
15-04-2004, 09:27
l'interfaccia è su?

Meridian
15-04-2004, 09:28
Certo... sia eth0 che ippp0

gianiaz
15-04-2004, 09:31
sei sicuro?
Il punto è che per pingare un pc non ti serve nessuna tabella di routing, l'unica cosa che deve essere assicurata è la connessione fisica e la coerenza degli ip (devono essere sulla stessa rete).
Visto che è cambiato tutto in un colpo io penserei + ad una di queste 2 possibilità:

1) se hai un hub od uno switch in rete questo ti si è impiantato.
2) la scheda di rete è giù
3) i cavi sono stati tagliati

:ciauz:

Meridian
15-04-2004, 09:33
Scusa hai ragione. Ho dimenticato di dire alcune cose fondamentali :(

Riesco tranquillamente a pingare gli indirizzi IP presenti sulla mia stessa lan, ma non quelli di altre lan. Per questo facevo riferimento al gateway. Ed ovviamente pingo i puri ip address e non i nomi host perchè i dns sono su una lan differente.

gianiaz
15-04-2004, 09:41
bhe comunque per aggiungere il gateway basta che dai questo comando:

route add default gw indirizzoipgateway

Meridian
15-04-2004, 09:48
E cosa ci metto? Il gateway della mia LAN? Non credo poi serva molto per gli host su internet... non credi?

Meridian
15-04-2004, 09:51
Infatti... ho inserito il gateway della mia lan. Ora pingo correttamente tutta la mia lan/wan.
Mentre per gli host su internet non mi tornano i pacchetti perchè non seguo il giusto percorso.

gianiaz
15-04-2004, 10:12
purtroppo non conosco la connessione isdn in linux, ma se funziona come l'adsl e le connessioni via modem analogico non credo che serva mettere nessun default gateway all'esterno.

questo indirizzo riesci a pingarlo?
66.102.11.104 (www.google.com)

potresti aver perso solamente il file resolv.conf che contiene gli indirizzi dei dns.

gigyz
15-04-2004, 10:30
non esiste solo il default gw ma possono esserci tanti gateway verso più reti in particolare:
10.62.12.0 * 255.255.255.0 U 0 0 0 eth0
è l'instradamento verso la lan sempre che sia giusto (se non dici com'è fatta la tua lan chi può dirlo :bhò: )
quindi ciò che ti manca è il default gw settato sull'ip del server del tuo isp ma prima ci vuole l'instradamento verso quell'ip che dovrebbe essere
62.0.0.0 * 255.0.0.0 U 0 0 0 ippp0
ma questo è sbagliato deve essere
ipdell_isp * 255.255.255.255 U 0 0 0 ippp0
poi con route add default gw ipdell_isp
crei la giusta route del default gw e se i DNS sono a posto puoi navigare

Loading