PDA

Visualizza la versione completa : [Gentoo 2004.0] Alcuni problemi


mschievano
16-04-2004, 19:59
Alcuni problemi su gentoo:

1. non mi vede il CD-ROM
2. il kernel 2.6.5 si blocca in booting poichè non trova il modulo aacraid (il 2.4.25-gentoo funziona)
3. non carica il modulo rivafb:


bash-2.05b# modprobe rivafb
/lib/modules/2.4.25-gentoo/kernel/drivers/video/riva/rivafb.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.25-gentoo/kernel/drivers/video/riva/rivafb.o: insmod
/lib/modules/2.4.25-gentoo/kernel/drivers/video/riva/rivafb.o failed
/lib/modules/2.4.25-gentoo/kernel/drivers/video/riva/rivafb.o: insmod rivafb failed

4. il mouse ha la rotellina che non va
:dhò:

maiosyet
16-04-2004, 20:12
Originariamente inviato da mschievano
Alcuni problemi su gentoo:

4. il mouse ha la rotellina che non va


In XF86Config:



Section "Pointer"
Protocol "IMPS/2"
Device "/dev/usbmouse"
ZAxisMapping 4 5
EndSection


Se hai un mouse usb

andy caps
16-04-2004, 21:35
per il cdrom devi mettere il modulo per i cdrom dal ATA/ATAPI/MFM/RLL support <*> Include IDE/ATAPI CDROM support

comunque prova a montarlo manualmente con es

mount /dev/hdc -t iso9660 /mnt/cdrom
per il modulo aacraid prova a metterlo ricompilando il kernel
probabilmente il tuo pc ha un controller adaptec
SCSI low-level drivers >

< > Adaptec AACRAID support (EXPERIMENTAL)

rivafb non serve a molto

le riva dovrebbero essere supportate dai driver nvidia lascialo perdere tranquillamente
per la rotellina come dice maiosyet se hai un mouse usb
altrimenti se hai un normale ps2 con rotellina

metti come me io ho due sezioni
Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/psaux"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Generic Mouse"
Driver "mouse"
Option "SendCoreEvents" "true"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

mschievano
16-04-2004, 22:37
kde non parte all'avvio nonostante abbia modificato il file make.conf e i profile

andy caps
16-04-2004, 22:45
per fare partire kdm all'avvio devi modificare /etc/rc.conf

devi mettere cosi

DISPLAYMANAGER="kdm"
e in fondo
XSESSION="Kde-3.2.1"


poi con kdm parte kdm e con startx parte kde

se vuoi fare partire kdm al boot digita

rc-update add xdm default

alex86
16-04-2004, 22:47
Originariamente inviato da mschievano
kde non parte all'avvio nonostante abbia modificato il file make.conf e i profile

ma da qlke errore a video o nn succede nulla (ad esempio nn si vede la skermata di login...)

fai startx?magari nn c'è l'avvio automatico di kde..

mschievano
17-04-2004, 15:55
non da errori.
ora ho aggiunto il servizio di default e lo testo (rc-update)

purtroppo per il cd sembra non esserci storia, e per il mouse usb cordless logitech la rotella non scorre nonostante la modifica in XF86config...

almafer
17-04-2004, 15:58
ma un dmesg te lo vede il cdrom?
leggi per bene tutta la doc, ti sarai dimenticato qualcosa nel kernel per il mouse

NonnoBassotto
17-04-2004, 16:01
Originariamente inviato da mschievano
non da errori.
ora ho aggiunto il servizio di default e lo testo (rc-update)

purtroppo per il cd sembra non esserci storia, e per il mouse usb cordless logitech la rotella non scorre nonostante la modifica in XF86config...

Per il mouse, se hai messo i moduli nel kernel, prova a compilarli a parte e a caricarli. Ho avuto il tuo stesso problema e, dopo infinite tribolazioni, ho scoperto che gli stessi moduli caricati a parte... funzionavano!

mschievano
17-04-2004, 16:05
der: 0, 4096 bytes)
Buffer cache hash table entries: 32768 (order: 5, 131072 bytes)
Page-cache hash table entries: 131072 (order: 7, 524288 bytes)
CPU: CLK_CTL MSR was 6003d22f. Reprogramming to 2003d22f
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 64K (64 bytes/line)
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU: After generic, caps: 0383fbff c1c3fbff 00000000 00000000
CPU: Common caps: 0383fbff c1c3fbff 00000000 00000000
CPU: AMD Unknown CPU Type stepping 01
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
enabled ExtINT on CPU#0
ESR value before enabling vector: 00000000
ESR value after enabling vector: 00000000
ENABLING IO-APIC IRQs
init IO_APIC IRQs
IO-APIC (apicid-pin) 2-0, 2-16, 2-17, 2-18, 2-19, 2-20, 2-21, 2-22, 2-23 not connected.
..TIMER: vector=0x31 pin1=2 pin2=-1
Using local APIC timer interrupts.
calibrating APIC timer ...
..... CPU clock speed is 1399.7985 MHz.
..... host bus clock speed is 266.6283 MHz.
cpu: 0, clocks: 2666283, slice: 1333141
CPU0<T0:2666272,T1:1333120,D:11,S:1333141,C:2666283>
mtrr: v1.40 (20010327) Richard Gooch (rgooch@atnf.csiro.au)
mtrr: detected mtrr type: Intel
ACPI: Subsystem revision 20040116
PCI: PCI BIOS revision 2.10 entry at 0xfb440, last bus=1
PCI: Using configuration type 1
tbxface-0117 [03] acpi_load_tables : ACPI Tables successfully acquired
Parsing all Control Methods:.......................................... .................................................. .............................................
Table [DSDT](id F004) - 497 Objects with 44 Devices 137 Methods 28 Regions
ACPI Namespace successfully loaded at root c0168d5c
IOAPIC[0]: Set PCI routing entry (2-9 -> 0x71 -> IRQ 9 Mode:1 Active:1)
evxfevnt-0093 [04] acpi_enable : Transition to ACPI mode successful
evgpeblk-0747 [06] ev_create_gpe_block : GPE 00 to 15 [_GPE] 2 regs at 0000000000004020 on int 9
Completing Region/Field/Buffer/Package initialization:................................... .........................................
Initialized 28/28 Regions 13/13 Fields 20/20 Buffers 15/15 Packages (505 nodes)
Executing all Device _STA and_INI methods:.......................................... ....
46 Devices found containing: 46 _STA, 2 _INI methods
IO APIC #2......
.... register #00: 02000000
PCI: Using ACPI for IRQ routing
PCI: if you experience problems, try using option 'pci=noacpi' or even 'acpi=off'
PCI: Via IRQ fixup for 00:11.2, from 12 to 5
PCI: Via IRQ fixup for 00:11.3, from 12 to 5
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
Starting kswapd
VFS: Disk quotas vdquot_6.5.1
devfs: v1.12c (20020818) Richard Gooch (rgooch@atnf.csiro.au)
devfs: boot_options: 0x1
Detected PS/2 Mouse Port.
pty: 256 Unix98 ptys configured
Serial driver version 5.05c (2001-07-08) with HUB-6 MANY_PORTS MULTIPORT SHARE_IRQ SERIAL_PCI ISAPNP enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A
Real Time Clock Driver v1.10f
Non-volatile memory driver v1.2
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
NET4: Frame Diverter 0.46
COMX: driver version 0.85 (C) 1995-1999 ITConsult-Pro Co. <info@itc.hu>
RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
Uniform Multi-Platform E-IDE driver Revision: 7.00beta4-2.4
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
VP_IDE: IDE controller at PCI slot 00:11.1
VP_IDE: chipset revision 6
VP_IDE: not 100% native mode: will probe irqs later
VP_IDE: VIA vt8233a (rev 00) IDE UDMA133 controller on pci00:11.1
ide0: BM-DMA at 0xdc00-0xdc07, BIOS settings: hda:DMA, hdb:DMA
ide1: BM-DMA at 0xdc08-0xdc0f, BIOS settings: hdc:DMA, hdd:DMA
hda: C/H/S=39236/16/255 from BIOS ignored
hda: Maxtor 6Y080L0, ATA DISK drive
hdb: QUANTUM FIREBALLlct15 20, ATA DISK drive
blk: queue c0183620, I/O limit 4095Mb (mask 0xffffffff)
blk: queue c018375c, I/O limit 4095Mb (mask 0xffffffff)
hdc: CDD7052, ATAPI CD/DVD-ROM drive
hdd: LITEON DVD-ROM LTD163D, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: attached ide-disk driver.
hda: host protected area => 1
hda: 160086528 sectors (81964 MB) w/2048KiB Cache, CHS=158816/16/63, UDMA(133)
hdb: attached ide-disk driver.
hdb: host protected area => 1
hdb: 39876480 sectors (20417 MB) w/418KiB Cache, CHS=2482/255/63, UDMA(66)
Partition check:
/dev/ide/host0/bus0/target0/lun0: p1 p2 p3 p4 < p5 p6 >
/dev/ide/host0/bus0/target1/lun0: p1
ide: late registration of driver.
md: linear personality registered as nr 1
md: raid0 personality registered as nr 2
md: raid1 personality registered as nr 3
md: raid5 personality registered as nr 4
raid5: measuring checksumming speed
8regs : 2132.400 MB/sec
32regs : 1375.200 MB/sec
pIII_sse : 3794.400 MB/sec
pII_mmx : 3274.800 MB/sec
p5_mmx : 4205.200 MB/sec
raid5: using function: pIII_sse (3794.400 MB/sec)
md: multipath personality registered as nr 7
md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
LVM version 1.0.8(17/11/2003)
device-mapper: 4.0.5-ioctl (2003-11-18) initialised: dm@uk.sistina.com
Initializing Cryptographic API
IEEE 802.2 LLC for Linux 2.1 (c) 1996 Tim Alpaerts
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 4096 buckets, 32Kbytes
TCP: Hash tables configured (established 32768 bind 65536)
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
IPv6 v0.8 for NET4.0
IPv6 over IPv4 tunneling driver
divert: not allocating divert_blk for non-ethernet device sit0
RAMDISK: Compressed image found at block 0
Freeing initrd memory: 1937k freed
VFS: Mounted root (ext2 filesystem).
Mounted devfs on /dev
attempt to access beyond end of device
01:00: rw=0, want=4168, limit=4096
attempt to access beyond end of device
01:00: rw=0, want=4169, limit=4096
attempt to access beyond end of device
01:00: rw=0, want=4170, limit=4096
attempt to access beyond end of device
01:00: rw=0, want=4171, limit=4096
reiserfs: found format "3.6" with standard journal
reiserfs: checking transaction log (device ide0(3,3)) ...
for (ide0(3,3))
ide0(3,3):Using r5 hash to sort names
VFS: Mounted root (reiserfs filesystem) readonly.
Trying to move old root to /initrd ... failed
Unmounting old root
Trying to free ramdisk memory ... okay
Mounted devfs on /dev
Freeing unused kernel memory: 156k freed
Adding Swap: 500464k swap-space (priority -1)
Journalled Block Device driver loaded
kjournald starting. Commit interval 5 seconds
EXT3-fs warning: maximal mount count reached, running e2fsck is recommended
EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,1), internal journal
EXT3-fs: mounted filesystem with ordered data mode.
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
rivafb: RIVA MTRR set to ON
Console: switching to colour frame buffer device 80x30
rivafb: PCI nVidia NV10 framebuffer ver 0.9.4 (GeForce2-MX, 64MB @ 0xE0000000)
uhci.c: USB Universal Host Controller Interface driver v1.1
uhci.c: USB UHCI at I/O 0xe000, IRQ 21
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
uhci.c: USB UHCI at I/O 0xe400, IRQ 21
usb.c: new USB bus registered, assigned bus number 2
hub.c: USB hub found
hub.c: 2 ports detected
gameport0: Emu10k1 Gameport at 0xd800 size 8 speed 1193 kHz
Creative EMU10K1 PCI Audio Driver, version 0.20a, 22:51:22 Apr 13 2004
emu10k1: EMU10K1 rev 7 model 0x8040 found, IO at 0xd400-0xd41f, IRQ 19
ac97_codec: AC97 Audio codec, id: 0x8384:0x7609 (SigmaTel STAC9721/23)
8139too Fast Ethernet driver 0.9.26
divert: allocating divert_blk for eth0
eth0: RealTek RTL8139 at 0xd000, 00:10:b5:06:4f:a2, IRQ 17
eth0: Identified 8139 chip type 'RTL-8139A'
hub.c: new USB device 00:11.2-1, assigned address 2
hub.c: USB hub found
hub.c: 4 ports detected
eth0: link up, 100Mbps, full-duplex, lpa 0x41E1
hub.c: new USB device 00:11.2-1.1, assigned address 3
usb.c: USB device 3 (vend/prod 0x46d/0xc504) is not claimed by any active driver.
hub.c: new USB device 00:11.2-1.2, assigned address 4
usb.c: USB device 4 (vend/prod 0x4a9/0x105c) is not claimed by any active driver.
usbdevfs: USBDEVFS_CONTROL failed dev 3 rqt 128 rq 6 len 59 ret -6
usb.c: registered new driver usbkbd
input0: Logitech USB Receiver on usb1:3.0
usbkbd.c: :USB HID Boot Protocol keyboard driver
usb.c: registered new driver hiddev
usb.c: registered new driver hid
usb.c: registered new driver usbmouse
usb.c: registered new driver usblp
input: USB HID v1.10 Mouse [Logitech USB Receiver] on usb1:3.1
printer.c: usblp0: USB Bidirectional printer dev 4 if 0 alt 0 proto 2 vid 0x04A9 pid 0x105C
hid-core.c: v1.8.1 Andreas Gal, Vojtech Pavlik <vojtech@suse.cz>
hid-core.c: USB HID support drivers
usbmouse.c: v1.6:USB HID Boot Protocol mouse driver
printer.c: v0.13: USB Printer Device Class driver
usbdevfs: USBDEVFS_CONTROL failed dev 3 rqt 128 rq 6 len 9 ret -6
mice: PS/2 mouse device common for all mice
eth0: no IPv6 routers present
SCSI subsystem driver Revision: 1.00
CSLIP: code copyright 1989 Regents of the University of California
PPP generic driver version 2.4.2
divert: not allocating divert_blk for non-ethernet device ppp0

Loading