PDA

Visualizza la versione completa : kernel sources & kernel headers


Max256
19-04-2004, 19:12
Ciao a tutti
ho da poco installato su un vecchio pc Libranet
la distro Ŕ basata su debian woody

tutto bene, la distro gira a meraviglia, tranne un piccolo grosso problema.
Ho necessitÓ di far funzionare un modem 56k interno instalalto su COM3
il MOdem Ŕ un conexant, e con i drivers ufficiali, su slackware riuscivo a farlo funzionare

Ieri mentre provavo a installare i driver, mi ha dato un errore di kernel-sources o kernel-headers mancanti
e nn mi permette di andare avanti

cosa devo fare??

Enrico81
19-04-2004, 19:15
debian:~# apt-cache search kernel-source
freeswan - IPSEC utilities for FreeSWan
kernel-patch-2.2-lids - LIDS Kernel Patch
kernel-patch-2.4-lids - LIDS Kernel Patch
kernel-patch-debian-2.4.21 - Debian patches to Linux 2.4.21
kernel-patch-debian-2.4.22 - Debian patches to Linux 2.4.22
kernel-patch-debian-2.4.24 - Debian patches to Linux 2.4.24
kernel-patch-debian-2.4.25 - Debian patches to Linux 2.4.25
kernel-patch-debian-2.6.3 - Debian patches to Linux 2.6.3
kernel-patch-debian-2.6.4 - Debian patches to Linux 2.6.4
kernel-patch-debian-2.6.5 - Debian patches to Linux 2.6.5
kernel-patch-usagi - Another IPv6 implementation for Linux
kernel-source-2.2.25 - Linux kernel source for version 2.2.25
kernel-source-2.4.19 - Linux kernel source for version 2.4.19
kernel-source-2.4.20 - Linux kernel source for version 2.4.20 with Debian patches
kernel-source-2.4.21 - Linux kernel source for version 2.4.21 with Debian patches
kernel-source-2.4.22 - Linux kernel source for version 2.4.22 with Debian patches
kernel-source-2.4.24 - Linux kernel source for version 2.4.24 with Debian patches
kernel-source-2.4.25 - Linux kernel source for version 2.4.25 with Debian patches
kernel-source-2.6.3 - Linux kernel source for version 2.6.3 with Debian patches
kernel-source-2.6.4 - Linux kernel source for version 2.6.4 with Debian patches
kernel-source-2.6.5 - Linux kernel source for version 2.6.5 with Debian patches
lidstools-2.2 - LIDS Admintool
lidstools-2.4 - LIDS Admintool
oprofile - system-wide profiler for x86/ia64 systems
nvidia-glx - NVIDIA binary XFree86 4.x driver
nvidia-kernel-source - NVIDIA binary kernel module source



debian:~# apt-cache search kernel-headers
dvb-dev - Dummy package for upgrade purposes only
kernel-headers-2.2.20-sparc - Kernel header files for all sparc sub architectures
kernel-headers-2.4.18-bf2.4 - Headers for Linux kernel version 2.4.18 (bf variant) on 386
kernel-headers-2.4.24-speakup - Header files related to Linux kernel version 2.4.24-speakup
kernel-headers-2.4.25-1 - Header files related to Linux kernel version 2.4.25
kernel-headers-2.4.25-1-386 - Linux kernel headers 2.4.25 on 386
kernel-headers-2.4.25-1-586tsc - Linux kernel headers 2.4.25 on Pentium-Classic
kernel-headers-2.4.25-1-686 - Linux kernel headers 2.4.25 on PPro/Celeron/PII/PIII/PIV
kernel-headers-2.4.25-1-686-smp - Linux kernel headers 2.4.25 on PPro/Celeron/PII/PIII/PIV SMP
kernel-headers-2.4.25-1-k6 - Linux kernel headers 2.4.25 on AMD K6/K6-II/K6-III
kernel-headers-2.4.25-1-k7 - Linux kernel headers 2.4.25 on AMD K7
kernel-headers-2.4.25-1-k7-smp - Linux kernel headers 2.4.25 on AMD K7 SMP
kernel-headers-2.6-386 - Linux kernel headers 2.6 on 386
kernel-headers-2.6-686 - Linux kernel headers 2.6 on PPro/Celeron/PII/PIII/PIV
kernel-headers-2.6-686-smp - Linux kernel headers 2.6 on PPro/Celeron/PII/PIII/PIV SMP
kernel-headers-2.6-k7 - Linux kernel headers 2.6 on AMD K7
kernel-headers-2.6-k7-smp - Linux kernel headers 2.6 on AMD K7 SMP
kernel-headers-2.6.3-1 - Header files related to Linux kernel version 2.6.3
kernel-headers-2.6.3-1-386 - Linux kernel headers 2.6.3 on 386
kernel-headers-2.6.3-1-686 - Linux kernel headers 2.6.3 on PPro/Celeron/PII/PIII/PIV
kernel-headers-2.6.3-1-686-smp - Linux kernel headers 2.6.3 on PPro/Celeron/PII/PIII/PIV SMP
kernel-headers-2.6.3-1-k7 - Linux kernel headers 2.6.3 on AMD K7
kernel-headers-2.6.3-1-k7-smp - Linux kernel headers 2.6.3 on AMD K7 SMP
kernel-headers-2.6.4-1 - Header files related to Linux kernel version 2.6.4
kernel-headers-2.6.4-1-386 - Linux kernel headers 2.6.4 on 386
kernel-headers-2.6.4-1-686 - Linux kernel headers 2.6.4 on PPro/Celeron/PII/PIII/PIV
kernel-headers-2.6.4-1-686-smp - Linux kernel headers 2.6.4 on PPro/Celeron/PII/PIII/PIV SMP
kernel-headers-2.6.4-1-k7 - Linux kernel headers 2.6.4 on AMD K7
kernel-headers-2.6.4-1-k7-smp - Linux kernel headers 2.6.4 on AMD K7 SMP
kernel-headers-2.6.5-1 - Header files related to Linux kernel version 2.6.5
kernel-headers-2.6.5-1-386 - Linux kernel headers 2.6.5 on 386
kernel-headers-2.6.5-1-686 - Linux kernel headers 2.6.5 on PPro/Celeron/PII/PIII/PIV
kernel-headers-2.6.5-1-686-smp - Linux kernel headers 2.6.5 on PPro/Celeron/PII/PIII/PIV SMP
kernel-headers-2.6.5-1-k7 - Linux kernel headers 2.6.5 on AMD K7
kernel-headers-2.6.5-1-k7-smp - Linux kernel headers 2.6.5 on AMD K7 SMP
kernel-kbuild-2.6-1 - Linux kernel 2.6 kbuild tools
kernel-package - A utility for building Linux kernel related Debian packages.
linux-kernel-headers - Linux Kernel Headers for development
debian:~#

Usa apt e installa quello che ti serve.

Sergio Pedone
19-04-2004, 19:15
scaricarti i sorgenti del kernel
della versione che utilizzi(uname -r)

ciao

Max256
19-04-2004, 20:30
ho scaricato i sorgenti ma riprovano l'installazione mi da sempre lo stesso errore

---------------------------------------------------------------
Configuro hsfmodem (6.03.00lnxt04032800full) ...
Conexant HSF softmodem driver, version 6.03.00lnxt04032800full

If you need license keys, assistance or more information, please go to:
http://www.linuxant.com/

When reporting a problem for the first time, please send
us the file generated by "hsfconfig --dumpdiag".

No pre-built modules for: Debian-testing/unstable linux-2.6.3 i686-SMP

Trying to automatically build the driver modules...
(this requires a C compiler and proper kernel sources to be installed)

ERROR: /lib/modules/2.6.3/build points to a missing directory

lrwxrwxrwx 1 root root 20 Apr 18 16:17 /lib/modules/2.6.3/build -> /usr/src/linux-2.6.3

Please ensure that the kernel-headers or kernel-source package is installed.
dpkg: errore processando hsfmodem (--configure):
il sottoprocesso post-installation script ha restituito un codice di errore 1
Sono occorsi degli errori processando:
hsfmodem
------------------------------------------------------------

andy caps
19-04-2004, 20:44
linux-2.6.3 i686-SMP

ma hai installato un kernel per multiprocessore ?

dai un uname -r ed installa quelli corretti

Max256
20-04-2004, 01:55
il risultato di uname -r Ŕ


root@debianbox:~# uname -r
2.6.3
root@debianbox:~#


ho ridato apt-cache search kernel-sources

questo il risultato:

freeswan - IPSEC utilities for FreeSWan
kernel-patch-2.2-lids - LIDS Kernel Patch
kernel-patch-2.4-lids - LIDS Kernel Patch
kernel-patch-debian-2.4.21 - Debian patches to Linux 2.4.21
kernel-patch-debian-2.4.22 - Debian patches to Linux 2.4.22
kernel-patch-debian-2.4.24 - Debian patches to Linux 2.4.24
kernel-patch-debian-2.4.25 - Debian patches to Linux 2.4.25
kernel-patch-debian-2.6.3 - Debian patches to Linux 2.6.3
kernel-patch-debian-2.6.4 - Debian patches to Linux 2.6.4
kernel-patch-debian-2.6.5 - Debian patches to Linux 2.6.5
kernel-patch-usagi - Another IPv6 implementation for Linux
kernel-source-2.2.25 - Linux kernel source for version 2.2.25
kernel-source-2.4.19 - Linux kernel source for version 2.4.19
kernel-source-2.4.20 - Linux kernel source for version 2.4.20 with Debian patches
kernel-source-2.4.21 - Linux kernel source for version 2.4.21 with Debian patches
kernel-source-2.4.22 - Linux kernel source for version 2.4.22 with Debian patches
kernel-source-2.4.24 - Linux kernel source for version 2.4.24 with Debian patches
kernel-source-2.4.25 - Linux kernel source for version 2.4.25 with Debian patches
kernel-source-2.6.3 - Linux kernel source for version 2.6.3 with Debian patches
kernel-source-2.6.4 - Linux kernel source for version 2.6.4 with Debian patches
kernel-source-2.6.5 - Linux kernel source for version 2.6.5 with Debian patches
lidstools-2.2 - LIDS Admintool
lidstools-2.4 - LIDS Admintool
oprofile - system-wide profiler for x86/ia64 systems
nvidia-glx - NVIDIA binary XFree86 4.x driver
nvidia-kernel-source - NVIDIA binary kernel module source
------------------------------------------------------------

ed ho installo apt-get install kernel-source-2.6.3

ma mi da sempre lo stesso identico errore

andy caps
20-04-2004, 07:49
dai un apt-get install kernel-headers-2.6.3-1


poi dai un

cd /usr/src
poi

ln -s linux-2.6.3 linux

poi riprova

andy caps
20-04-2004, 07:53
il driver hai scaricato questo ?

http://www.linuxant.com/drivers/hsf/full/archive/hsfmodem-6.03.00lnxt04032800full/hsfmodem_6.03.00lnxt04032800full_i386.deb


e lo stai installando con dpkg -i ?

Max256
20-04-2004, 14:09
Originariamente inviato da andy caps
il driver hai scaricato questo ?

http://www.linuxant.com/drivers/hsf/full/archive/hsfmodem-6.03.00lnxt04032800full/hsfmodem_6.03.00lnxt04032800full_i386.deb


e lo stai installando con dpkg -i ?

si esatto

Max256
20-04-2004, 14:13
Originariamente inviato da andy caps
dai un apt-get install kernel-headers-2.6.3-1


poi dai un

cd /usr/src
poi

ln -s linux-2.6.3 linux

poi riprova

ho seguito questa procedura, ma nulla sempre lo stesso identico errore :(

Loading