PDA

Visualizza la versione completa : Ricompilato il kernel ma adesso ho perso lo splash screen


abmcr
22-04-2004, 19:00
Dopo n (--> 10) tentativi sno riuscito a ricompilare il keernel di MDK 10. Adesso nel menù di Grub ho ovviamente la voce 263-4.... che fa riferimento al mio kernel nuovo. Se la scelho il sistema parte OK, ma vedo tutto il listato (non è che faccia schifo, ma è più che altro una curiosità) mentre in origine vedevo uno splash screen con tanto di barra di scorrimento. Come faccio a farla apparire anche col nuovo kernel?
E poi ( :( ): come si fa a cambiare la dimensione di icone e dei font del testo del menù che si attiva se si schiaccia la K di kde?
Sono newbie (15 giorni di Linux), per cui vi prego di perdonare le domande forse troppo banali, ma non so dove altro chiedere perché tra i colleghi sono l'unico che crede nel pinguino e che vuole arrivare a farlo andare per poi sviluppare. Grazie

weatherman
22-04-2004, 20:47
in grub hai inserito una cosa del tipo:
splashimage=(hd0,0)/grub/splash.xpm.gz ?

Edit: scusa ma mi sono accorto che la mia risposta non e` probabilmente quello che vuoi.

osiryx
22-04-2004, 21:37
Nn è che si riferisce al bootsplash ??

Fool
22-04-2004, 21:49
Originariamente inviato da osiryx
Nn è che si riferisce al bootsplash ??

Mi sa di si.

Mi pare che vada impostato in qualchenfile,centra poco col kernel

francofait
22-04-2004, 23:05
Originariamente inviato da Fool
Mi sa di si.

Mi pare che vada impostato in qualchenfile,centra poco col kernel

Metti semplicemente

vga=791

IroN@xiD
22-04-2004, 23:26
succede lo stesso regolarmente anche a me con qualsiasi versione di mandrake... adesso magari non ci credete ma sono appena arrivato sul forum per chiedere la stessa cosa!
Ho fatto un pò di approfondimento sul tema prima...
Io uso lilo come bootloader e c'è una stringa nella configurazione di lilo (/etc/lilo.conf) dove si può specificare il caricamento con bootloader..
Precisamente questa..

image=/boot/vmlinuz-new
label="mylinux"
root=/dev/hda6
initrd=/boot/initrd-2.4.22-0.28mdk.img
append="devfs=mount hdd=ide-scsi acpi=ht resume=/dev/hda5 splash=silent"
vga=791
read-only

Inserita quella scritta però il bootloader dev'essere anche compilato nel kernel ovviamente per poter essere avviato..
C'è un apposita opzione in

console drivers -> frame buffer support -> use splash screen instead etc etc

Poi splashscreen dev'essere installato nel sistema e mdk ce l'ha già però c'è sempre qualcosa che mi sfugge purtroppo :(

Se qualcuno sa cos'è questa cosa che mi sfugge mi risolve un grosso problema!

VOGLIO IL CAPPELLAIO MATTO ALL'AVVIO!!!!!

"Un buon non compleanno, a me! a te!"

*si spalma un po' di burro nell'orologio e lo inzuppa nel the*

:biifu:

IroN@xiD
22-04-2004, 23:49
Originariamente inviato da ciromosketta
se parla di progress bar all'avvio è sicuramente il bootsplash. Se i sorgenti del tuo kernel sono già patchati, dovresti trovare in Device drivers --> Grapichs --> Bootsplash una voce da abilitare, che riguarda proprio il bootsplash...ti rimando al sito (http://www.bootsplash.org) ufficiale

anche abilitandolo purtroppo non funziona, ho già provato ma purtroppo niente da fare :(

IroN@xiD
23-04-2004, 00:26
ci sono riuscito dando un occhiata a questa guida (http://www.linuxforum.com/tutcomments/26/115.php) ;)
Per ora ho messo l'esempio..
Avevi ragione tu, in effetti serviva il mkinitdir!
Cmq non si capisce perchè dopo la ricompilazione del kernel non mi abbia preso il bootsplash...
Dopo aver ricompilato il kernel infatti avevo fatto il mkinitdir!! :bhò:

Siddhartha
23-04-2004, 02:19
Originariamente inviato da ciromosketta
bisogna passare al bootloader anche l'initrd, altrimenti non funziona nulla. E nell'initrd bisogna metterci l'immagine di splash. nel sito è spiegato bene


qlcn mi dà una veloce delucidzione sull'initrd?
nel mio lilo.conf non c'è alcun riferimento all'initrd eppure la distro boota lo stesso (lo vedo invece nel lilo.conf postato da iron)...a cosa serve questa opzione?
grazie 10000

abmcr
23-04-2004, 15:42
Scusate il ritardo: grazie a tutti innanzitutto; quindi alla fine ho capito che non ho selezionato la voce del kernel. Però che peccato perché adesso non ho coraggio a ricompilarlo di nuovo "solo" per inserire il bootsplash.

Loading