PDA

Visualizza la versione completa : problema mount hd usb


nesquik
24-04-2004, 15:41
ciao ragazzi... non riesco a montare un hd usb... :(

questo e' il risultato del dmesg, sapete aiutarmi ? thx



Initializing USB Mass Storage driver...
usb.c: registered new driver usb-storage
scsi1 : SCSI emulation for USB Mass Storage devices
Vendor: l l l l Model: l l l l l l l l Rev: l l
Type: Direct-Access ANSI SCSI revision: 02
Attached scsi disk sda at scsi1, channel 0, id 0, lun 0
SCSI device sda: 1 512-byte hdwr sectors (0 MB)
sda: I/O error: dev 08:00, sector 0
I/O error: dev 08:00, sector 0
usb.c: registered new driver usbscanner
ldm_validate_partition_table(): Disk read failed.
I/O error: dev 08:00, sector 0
unable to read partition table
WARNING: USB Mass Storage data integrity not assured
USB Mass Storage device found at 2
USB Mass Storage support registered.

fra7576
24-04-2004, 16:09
dovrebbe essere il device sda1

che probemi hai ??

nesquik
24-04-2004, 16:21
che ho provato /dev/sd* senza successo...

mount: sd* is not a valid block device

:dh:

sthra
24-04-2004, 16:31
cosa ti dice lsusb?

nesquik
24-04-2004, 20:37
ecco:

Unknown line at line 1809
Duplicate HUT Usage Spec at line 2650
Bus 004 Device 001: ID 0000:0000 Virtual Hub
Bus 003 Device 001: ID 0000:0000 Virtual Hub
Bus 002 Device 001: ID 0000:0000 Virtual Hub
Bus 002 Device 002: ID 046d:0840 Logitech Inc. QuickCam Express
Bus 002 Device 003: ID 04b8:010f Seiko Epson Corp. Perfection 1250
Bus 001 Device 001: ID 0000:0000 Virtual Hub
Bus 001 Device 002: ID 04cf:8813 Myson Technology Inc.

sthra
25-04-2004, 09:49
Immagino che sia il Myson Technology Inc.
prova lasciando inserito solo lui nell'usb a fare da root sta roba
for i in $(ls /dev/sd*); do mount -t auto $i /mnt/hdusb/;
dovrebbe sgamartelo se no il problema un altro

PS: nel tuo dmesg c `sta roba 'SCSI emulation for USB Mass Storage devices'
non capisco tanto il senso di una emulazione scsi su una usb perch non ne ho mai fatte, per se funza dovrebbe spostarti i device e farteli funzionare su sr invece che su sd, prova a montare anche gli sr allora.

nesquik
26-04-2004, 08:40
ho provato sia tutti gli sd* che tutti gli sr* ma nulla...
:dh: :dh: :dh: :dh:

almafer
26-04-2004, 09:22
ldm_validate_partition_table(): Disk read failed.
I/O error: dev 08:00, sector 0
unable to read partition table


io proverei a formattarlo di nuovo

sthra
26-04-2004, 10:10
allora il tuo dmesg

SCSI device sda: 1 512-byte hdwr sectors (0 MB)
sda: I/O error: dev 08:00, sector 0
I/O error: dev 08:00, sector 0

ecco come dovrebbe essere un dmesg senza errori per un MASS storage
hub.c: new USB device 00:02.0-2, assigned address 2
usb.c: USB device 2 (vend/prod 0x839/0xe) is not claimed by any active driver.
Initializing USB Mass Storage driver...
usb.c: registered new driver usb-storage
scsi1 : SCSI emulation for USB Mass Storage devices
Vendor: SAMSUNG Model: DIGIMAX 360 Rev: 1.00
Type: Direct-Access ANSI SCSI revision: 02
Attached scsi removable disk sda at scsi1, channel 0, id 0, lun 0
SCSI device sda: 498176 512-byte hdwr sectors (255 MB)
sda: Write Protect is off
sda: sda1
WARNING: USB Mass Storage data integrity not assured
USB Mass Storage device found at 2
USB Mass Storage support registered.

Quindi se tu facessi cat /proc/scsi/scsi che ti dice? e se fai ls /proc/scsi ti ha creato una cartella tipo usb-mass-storage?

nesquik
26-04-2004, 12:16
ecco l'output:

root@portatile:# cat /proc/scsi/scsi
Attached devices:
Host: scsi1 Channel: 00 Id: 00 Lun: 00
Vendor: l l l l Model: l l l l l l l l Rev: l l
Type: Direct-Access ANSI SCSI revision: 02
root@portatile:# ls /proc/scsi
ide-scsi scsi sg usb-storage-0


P.S. come faccio a formattarlo se non lo vedo ?

Intanto grazie per l'aiuto... :)

Loading