PDA

Visualizza la versione completa : mount e KDE 3.2


fandwick
28-04-2004, 23:18
Ho installato da un mesetto circo il KDE 3.2.

Esisteva l'automount del cdrom: non appena infilavo il cd lui me lo montava in automatico.
Siccome però quando andavo a smontarlo, ricevevo sempre un errore, ho tolto (non ho cancellato, ma solo tolto) il file

/home/fandwick/.kde/Autostart/Autorun.desktop

In tal modo ora basta che clicco due volte sull'icona del cdrom che mi sono creato sul desktop, per avviare il mount del cd e navigarlo con Konqueror.
Purtroppo anche qui problemi a smontarlo. Konqueror non lo libera e devo andare in console, killare i processi di Konqueror e finalmente smontare il cdrom.

Se invece monto il cd da console e lo navigo da console, alla fine posso smontarlo tranquillamente, perché Konqueror non viene usato.

Oggi mi è successo anche con un floppy.

Insomma, Konq mi blocca le periferiche.

Come posso risolvere questo problema?

andy caps
29-04-2004, 00:07
prova se ti trovi bene con kwikdisk che trovi nel menu'

chiaramente per smontare le periferiche devi chiudere le finestre di konqueror ed eventuali consolle ch le stanno utilizzando

fandwick
29-04-2004, 00:21
Originariamente inviato da andy caps
prova se ti trovi bene con kwikdisk che trovi nel menu'


Ora proverò e ti farò sapere



chiaramente per smontare le periferiche devi chiudere le finestre di konqueror ed eventuali consolle ch le stanno utilizzando

beh, questo era implicito... insomma... vabbé che non sono un esperto, però... :D

fandwick
29-04-2004, 00:35
uhm uhm

Che devo fare con Kwikdisk? Vado nel menu, lo clicco, ma non succede nulla. C'è però una sua traccia, che poi vedrai.

Innanzitutto, se clicco col tasti destro sull'icona del cdrom e seleziono SMONTA, mi compare questa finestra:

http://utenti.lycos.it/fandwick/varie/foto19.jpeg

In teoria il device non dovrebbe essere occupato, perché nulla lo sta utilizzando. Però forse più avanti vedi che succede se uso la console.
Se invece tento di Fare un Eject, mi compaiono queste due:


http://utenti.lycos.it/fandwick/varie/foto20.jpeg


http://utenti.lycos.it/fandwick/varie/foto21.jpeg

Se vado in console, col ps aux trovo questi processi da interrompere al fine di riuscire a smontare il cdrom tramite umount:


fandwick 23139 0.0 2.1 104012 11268 ? S 20:22 0:00 kdeinit: kio_uiserver

fandwick 30867 0.0 4.4 110788 22676 ? S 22:15 0:03 kdeinit: konqueror --silent

fandwick 32313 0.0 2.6 100500 13560 ? S 23:21 0:00 kwikdisk -caption KwikDisk

fandwick 32320 0.0 2.6 101684 13560 ? S 23:22 0:00 kwikdisk -caption KwikDisk

fandwick 32377 0.0 1.2 25020 6308 ? S 23:25 0:00 kdeinit: kio_file file /tmp/ksocket-fandwick/klauncherBrJ0da.slave-socket /tmp/ksocket-fandwick/kwritep8RwEb.slave-socket

fandwick 32383 0.0 2.6 101464 13568 ? S 23:27 0:00 kwikdisk -caption KwikDisk


In particolare, se killo il

konqueror --silent

Allora riesco a smontare il device.
In mezzo ci trovi anche i vari Kwikdisk che ho provato ad avviare, senza successo.

andy caps
29-04-2004, 14:30
Kwikdisk una volta avviato mette un icona nella barra in basso e cliccando con il destro ti da la lista dei dischi montabili che si montano e smontano sempre con un clic
da li puoi definire anche il comando per l'umount
eject non lo trova perche probabilmente devi installarlo
non viene instalato si default da molte distro

fandwick
29-04-2004, 22:20
Aaaah, ecco perché Kwikdisk non capivo come funzionasse...
Sul desktop che ho non si vede il Vassoio di Sistema:

http://fandwick.altervista.org/pics/desktops/desktop4.jpg

andy caps
29-04-2004, 22:31
:D aggiungilo anche se è un peccato sciupare un desktop cosi clic dx sulla barra trasparente

fandwick
30-04-2004, 22:50
Ho risolto in altra maniera e mi sembra giusto postare il link:

Soluzione (http://www.quellicheilpc.com/forum/viewtopic.php?p=128905#128905)

Magari può tornare utile a qualcuno.

andy caps, grazie mille anche a te per avermi seguito.

:ciauz:

luigino
01-05-2004, 01:46
:ciauz:

Grasssie avevo lo stesso problema che mi stava facendo innervosire.


:mavieni:

Loading