PDA

Visualizza la versione completa : [Slack 9.0] Start X


kNemo
05-05-2004, 20:43
Ho appena installato la Slackware 9.0 (La mia Prima Slack)
Quando avvio il Sistema arrivo al login...
Faccio il login come root...
e fin qui tutto bene...
Ma quando cerco di lanciare x
# startx

mi carica qualcosa ma poi lo schermo mi va' in standby..
Come mai ??? come posso lanciare X ???

PS: Come si esce e come si salva con 'vi' o con 'vim' ???

Grazie.

Enrico81
05-05-2004, 20:46
Originariamente inviato da kNemo
Ho appena installato la Slackware 9.0 (La mia Prima Slack)
Quando avvio il Sistema arrivo al login...
Faccio il login come root...
e fin qui tutto bene...
Ma quando cerco di lanciare x
# startx

mi carica qualcosa ma poi lo schermo mi va' in standby..
Come mai ??? come posso lanciare X ???

PS: Come si esce e come si salva con 'vi' o con 'vim' ???

Grazie.

Creati un utente normale e poi lancia "xwmconfig" e scegli quello che vuoi, poi ridai startx.

kNemo
05-05-2004, 20:48
come si crea un utente da shell...
Sono un Principiante :D

Enrico81
05-05-2004, 20:59
Originariamente inviato da kNemo
come si crea un utente da shell...
Sono un Principiante :D

# useradd nome_utente -m -G users,wheel,games -s /bin/bash

# passwd nome_utente

Ho altrimenti lanci il comando che ti ho detto da root ed entri in kde poi vai nel menu, setting, kusers e aggiungi l'utente.

alex4988
05-05-2004, 21:00
Originariamente inviato da kNemo
come si crea un utente da shell...
Sono un Principiante :D
adduser

kNemo
05-05-2004, 21:03
una cosa...
Ma e' normale che X non parta all'avvio del sistema con root ?

maiosyet
05-05-2004, 21:05
Originariamente inviato da kNemo

PS: Come si esce e come si salva con 'vi' o con 'vim' ???



ESC
:
q < per uscire
wq < salvare e uscire
w! < uscire senza salvare

Enrico81
05-05-2004, 21:26
Originariamente inviato da kNemo
una cosa...
Ma e' normale che X non parta all'avvio del sistema con root ?

Alla fine dell'installazione, quando ti chiedeva di selezionare un WM di default nei hai scelto uno?

squid
05-05-2004, 21:40
Dal problema, cio da quello che ho capito, devi editare il file /etc/X11/XF86config secondo il tuo hardware, e secondo le tue preferenze.
Lo schermo va in standby per la 'frequenza troppo elevata', dovuta a diverse inpostazioni errate (alias='cannate').

k?
trovi alcuni howto sul file in questione... a meno che tu non lo conosci gi...

------------------------------------------

Poi:
non ti avvia X all'avvio perch devi impostare il runlevel a 4 nel file /etc/inittab.
Non mi ricordo di preciso la riga, ma cmq quella in cui si parla del runleve, e il numero fra due-duepunti (E.g.: :3: ), mettilo a 4 (vedi di impostare l'XF86config prima)!

:ciauz:

kNemo
05-05-2004, 21:48
penso che il mio problema sia dovuto a quello che dice squid
perche' anche scegliendo un wm non cambia niente...
cmq alla fine dell'installazione l'avevo scelto...

Loading