PDA

Visualizza la versione completa : Guaio....con Apache...e tutto il resto


biosimulant
05-05-2004, 23:39
Dall'ultimo post--->riepilogo per chi si fosse perso qualche puntata....
Ho un imac 450 MHZ, 320 MB di Ram, OsX 10.2.8 eun problema che mi fa uscire di senno....

Devo installare Apache2, php,Tomcat,Mysql (e' giusto l'ordine?)....
I guai sono cominciati quando,installato Apache e Tomcat decido di installare (piu' che altro devo installare anche php e mysql)...
Qualcuno mi dice:Apache,php,tomcat,mysql....OK vado su serverlogistics....mi scarico i binary evvai....3gg che sono qui a impazzire perche' a volte parte (tutto)....dico:
ce l'ho fatta!....spengo......disastro...non parte +nulla...
oggi,poi....peggio che peggio....riformatto il mac (aggiorno fino al 10.2.6) e reinstallo....l'apache parte...quasi nel senso che se gli chiedo "http://127.0.0.1:80/ o altre cose del genere,fioriscono a mitraglia gli error 404 e 500...perche' dove ho sbagliato?
Qualcuno mi puo' aiutare? mi sta venendo....l'esaurimento nervoso.....Grazie in anticipo...
P.S c'e' qualcosa,qualcuno che mi faccia sentire un po'meno idiota e abbia la pazienza di accompagnarmi in tutta l'installazione di apache,php,tomcat,mysql?
A proposito che versione e che ordine?Mi e' stato gia detto qualcosa...ma ormai mi sa che sono al dramma....

shishii
06-05-2004, 12:17
Ciao,

non conosco i metodi di istallazione di MacOSX, per prima cosa istalli dai sorgenti o usando i binari precompilati?

biosimulant
06-05-2004, 19:48
I pre-compilati della server-logistics.com per OS X 10.2 (Jaguar).....
Adesso (altra puntata della telenovela),tanto per cambiare s' rimesso a darmi gli errori 404 (e solo quelli) per il file di benvenuto piazzato nell' archivio dell'utente (e solo per quello)....ho paura a risvegliare php (gia' installato in un tentativo precedente) e a reinstallare mysql (chissa' che guai mi combinano.....)
Altre informazioni sul post di rettifica....

Grazie.....

shishii
07-05-2004, 13:14
Ciao,

dove settata la Document Root? guarda in httpd.conf

li dentro dovrebbe esserci un file index.html se c' richiamalo via browser con http://localhost/index.html e vediamo se funziona, se ti da errore 404 allora probabilmente non quella la Document Root.

biosimulant
07-05-2004, 19:27
Originariamente inviato da shishii
Ciao,

dove settata la Document Root? guarda in httpd.conf

li dentro dovrebbe esserci un file index.html se c' richiamalo via browser con http://localhost/index.html e vediamo se funziona, se ti da errore 404 allora probabilmente non quella la Document Root.

E' esattamente cio' che succede.....ma non per il computer (quello sembra a posto ).....ma quello per l'user.....
Quello che fa+ 0 - http://localhost/~user/index.html....
(non escludo errori di stampa....in questo momento sono troppo stanco per verificare se ho scritto giusto e ho almeno,una mezza dozzina di ore di sonno arretrato da smaltire....appena ho finito di rispondere alle lettere che mi sono giunte)....
verifichero',comunque.....Grazie....

shishii
07-05-2004, 19:33
Ciao,

ok allora devi guardare nella sezione di httpd.conf che si occupa delle user dir, deve essere settata cos:

<IfModule mod_userdir.c>

UserDir public_html

</IfModule>


<Directory /home/*/public_html>
AllowOverride FileInfo AuthConfig Limit
Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
<Limit GET POST OPTIONS>
Order allow,deny
Allow from all
</Limit>
<LimitExcept GET POST OPTIONS>
Order deny,allow
Deny from all
</LimitExcept>
</Directory>

mentre di default quanto sopra disabilitato.

biosimulant
07-05-2004, 19:45
Originariamente inviato da shishii
Ciao,

ok allora devi guardare nella sezione di httpd.conf che si occupa delle user dir, deve essere settata cos:

<IfModule mod_userdir.c>

UserDir public_html

</IfModule>


<Directory /home/*/public_html>
AllowOverride FileInfo AuthConfig Limit
Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
<Limit GET POST OPTIONS>
Order allow,deny
Allow from all
</Limit>
<LimitExcept GET POST OPTIONS>
Order deny,allow
Deny from all
</LimitExcept>
</Directory>

mentre di default quanto sopra disabilitato.

Vuoi dire che deve esserci scritto tutto quello?.....capperi.....Adesso che ci penso.... mi sembra di avere visto scritto di qualche problema con public_html (o qualcosa del genere)....
Gia' che ci siamo.....i previlegi di accesso (user--->lett.&scritt.) devono essere estesi al suo gruppo di lavoro o e' sufficiente l'admin?Tieni presente che su quel computer ci lavoro solo io.....
Ti sono grato per i consigli.....Mi stai aiutando a uscire da una crisi mistica senza precedenti...... :-) :-) ancora un po' ed ero sicuro che avrei avuto le visioni.....ho preso nota e' messo da parte....mi rifaro' vivo,come al solito....
Ancora grazie.....

shishii
08-05-2004, 10:54
di quali permessi di accesso parli?
alla public_html?

biosimulant
08-05-2004, 11:43
Originariamente inviato da shishii
di quali permessi di accesso parli?
alla public_html?

No...scusami....
Per entrare in alcune cartelle (httpd,conf e altre ho dovuto modificare alcuni permessi d'accesso....)vlevo solo sapere se il tipo di permesso (all'admin,allo staff o ad altri) aveva influenza su qualcosa di quelle cose (scusami il pasticcio di parole) a cui hi accennato negli altri post....
I Sist. Op. e le reti,nel caso non si fosse capito,non sono il mio forte.....

shishii
08-05-2004, 11:48
Tipico per un utente Mac :quote:

comunque le dir di /etc/httpd compresa devo essere chmod 755

Loading